Razer Blade 15 - FPS Shuttering in games, GPU not working properly, CPU issue? Help needed | Razer Insider
Question

Razer Blade 15 - FPS Shuttering in games, GPU not working properly, CPU issue? Help needed

  • 26 March 2023
  • 6 replies
  • 430 views

Hi everyone, I have an issue that I can't wrap my head around so I hope you can help me.

TLDR: After windows reinstall, I get FPS shattering, GPU temps run at ~60C while before reinstall used to run at ~75C, potential CPU limitation? basically my games are unplayable, I need some help. Please don't suggest checking if my drivers are updated.

--- specs ---
Razer Blade 15, Advance model 2009 (Product Number: RZ09-02887)
Intel Core i7-8750H CPU @ 2.2 GHz
16GB RAM
NVIDIA RTX 2070 Max-Q Design
Running Windows 11

--- story ---
Before windows reinstall I've used to play Call of Duty MW2 since the day it came out without any problems, running smooth, usually 75-80 FPS, GPU temp around ~75 these were the only telemetry I would run as everything was ok

This all changed once I reinstalled windows. I've been using this PC since 2019 for different purposes and I wanted to clean it for a while so I have a clean machine, dedicate for games, nothing from old software running in the background.

Since the reinstall, the game is basically unplayable. I my FPS is unstable, CPU usage seems to be 80-95%, GPU usage is fairly low, in the game menu my temperature goes to 65C, when playing drops to 58C, which pre-reinstall was the opposite, in game the temp would raise to ~70-75C.
In game I have total ram used 60% (9.57/15.9),total vram used 50% (3.97/7.83), GPU clock 1080 MHz, Memory Clock 6000 MHz, GPU Power 33 to 40 Watts, GPU Voltage 0.6 Volt.

 

r/razer - Razer Blade 15 - FPS Shuttering in games, GPU not working properly, CPU issue? Help needed

This is one session of "gaming" mainly ruining benchmarks and trying to play some multiplayer - you can see how the FPS is just jumping up and down

--- what I've done --- all based on support articles from razer and other sources and youtube videos I've found, I'm open to better suggestions

  1. Reinstalled windows from windows reset, after setting it up and installing the game, that's when I first started having this issues - thinking this might be a wrong approach for the sensitive razer laptops, I've reinstalled windows again with razer's system recovery, that should, in theory, set everything to how it came out of the factory - that's windows 10 from 2009

  2. I've updated all the drivers razer provides for this laptop model

  3. Then I installed all the windows updates - now running windows 11

  4. Tried different Nvidia drivers: the latest (531.41), the one activision suggests (526.86) uninstalling them with DDU while changing - had no effect whatsoever - now sticking with the one activision is recommending

  5. Nvidia control panel adjustments - tried several youtube videos from streamers explaining how it should be set up, resetting to default between each trial

  6. Power management from windows is set to performance

  7. Changing windows registry editor - again to the recommendation of streamers

  8. Disabling in game overlay from xbox game bar, all the nvidia overlays

  9. Stopping every app running in the background, changing the google chrome settings to stop running in the background (using ISLC to stop standby apps)

  10. Change options.3.codhq to have the correct thread count and video memory scale

  11. Tried all the different upscaling/sharpening settings - ran benchmarks with all, average FPS differs with the different settings but nothing solves the instability

  12. Enable weapon motion blur, v-sync on and off, run the game in everything low, run the game in everything maxed out, same performance

--- what I find weird ---

  1. The GPU temperature running lower after re-install - I feel like this is partly why I get unstable FPS

  2. CPU usage being high, could this be the problem? maybe the FPS instability comes from CPU throttling? Not sure how to check this or change settings on this or why this would be the case as it used to run perfectly

Any idea what could be the bottleneck or what could I try to run to understand better what's the issue? suggestions on what could I do to make my game be playable again are very welcome.

Thank you for reading all of this, I'm pretty desperate and not sure what else to do to fix this. Happy to provide any other information that could help solve this


6 Replies

I have the same problem than you. Games are running under 20fps for me on Razer Advance model. I tried everything that I found on the forum. No luck. 

I have the same problem

I’ve been recently having the same problem and have the exact same model.

This problem started after I installed latest Geforce Game ready drivers and Geforce Experience. So after trying everything I wiped the computer and on a clean slate there are no issues, good performance and no GPU throttling, when I updated the geforce drivers to 531.41 the problem began again. The GPU is only running on 10w-25w of power and constantly drops in voltage. 

This is useful @InsanePacman ! I’ll give this a try too, from the whole package from the Nvidia drivers, what did you have installed as I guess you would still need something installed to use the GPU.

Update: I uninstalled completely the drivers with DDU, and installed the Nvidia driver version 526.86

It is recommended by Activision, and as I’m trying to make Call of Duty work I started with this version as recommended here - https://support.activision.com/modern-warfare-ii/articles/modern-warfare-ii-pc-troubleshooting 

I did not install Game ready drivers and GeForce Experience and the stuttering reduced significantly. It’s way more smooth now.

However, I still don’t get the performance I had before reinstalling windows. My frames are around 25-30 while before reinstalling I used to play the same game with 65-70 FPS. My GPU temperature still doesn’t go higher then 65 degrees Celsius which before reinstall the game would run at around 75 degrees. 

When I run benchmarks inside the game, it show the CPU being a bottleneck constantly. 
Any ideas on how to fix this are welcome!
 

 

The same thing happens to me and I've been very sad I bought a razer blade advanced laptop with rtx 3070 and I didn't check the gpu and it all works and I barely play the boost clock stays at 780mhz and it starts to heat up abysmal, and I changed the pad paste reinstalled everything, even the razer support and nothing very sad the truth is something so expensive

Reply