Basilisk Ultimate Wireless won't charge over USB

Discussion in 'Razer Support' started by sharpAerotruck093, May 27, 2021.

Thread Status:
Not open for further replies.
  1. sharpAerotruck093

    sharpAerotruck093 New Member

    Has anyone experienced this same issue? It sounds insane to type this but I'm actually on mouse #4 of the wireless basilisk ultimate and all four times I've used the provided cable and plugged the mouse in using my desktop USB, my laptop's USB, and even just used a wall outlet USB as well and none of the four would charge through any connection. I've left it plugged in over night as well so the issue isn't related to amount of time. Additionally, to make sure it wasn't the cable I used it on an old phone of mine that's micro USB and it charged just fine.

    If others have had this problem and found a way to fix it please let me know as I'm somewhat tired of the RMA process at this point.
     
  2. Vandakter

    Vandakter New Member

    The exact same issue just started for me. My mouse is almost a year old, and charging through either the dock, or directly with the USB cable does nothing. The mouse stays at 5% no matter what.

    I'm not sure what to do at this point. I tried updating the firmware to 1.06 and that changed nothing either.
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey sharpAerotruck093! Have you tried charging it to a dock and check if the issue is the same? Have you updated the firmware of your Razer Basilisk Ultimate?

    Hello Vandakter. Try to isolate the behavior first by cleaning the pins of the dock using a Q-tip with an alcohol-based cleaning solution (at least 70% isopropyl alcohol) and see if it helps.

    Feel free to submit a case to our Support Team or send me a PM should you need additional assistance. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >