Basilisk X Hyperspeed not turning on even with different batteries

Discussion in 'Razer Support' started by hero6345, Sep 12, 2021.

Thread Status:
Not open for further replies.
  1. hero6345

    hero6345 New Member

    Today I took the mouse I turned it on with bluetooth and I noticed that it did not connect, I tried the connection via USB Dongle but it did not work, I tried to change new batteries even of different brands but the problem persisted, I noticed that when I turned it on with a new battery (in 2.4 mode) the mouse made a pattern of lights (green, green, red) I also tried to use different devices, a macbook and a windows pc
     
  2. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    Does it still work on a wired connection? Also, have you tried disabling Synapse to check if it behaves the same? For now, let's reinstall your mouse driver by following the steps on this page. PM me the serial number of your mouse should the issue persists. I can use that to verify its model and look for a way to fix this issue.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >