BlackShark V2 Pro Wireless Beeping

Discussion in 'Razer Support' started by GuppieGreensleektrend949, Nov 18, 2021.

Thread Status:
Not open for further replies.
  1. So I just received my Blackshark V2 pro in the mail today. After I charged it and connected it to my PC via the bluetooth dongle, it soon after started beeping, losing connection for split seconds and seemingly random intervals. I also have not been able to install Synapse 3 on my Windows 10 PC because I keep receiving a "Server access unavailable" error. The error persists even after I added Synapse to the exceptions to the Windows Firewall and restarted multiple times, as well as running the software as an admin. Any help would be appreciated, I feel like there's nothing else I can do.
     
  2. pfusella

    pfusella New Member

    I have had this issue since I bought them in August 2021. They're completely unusable. Been in contact with Razer for months and they're just completely useless. Like banging my head against a brick wall.
     
  3. Razer.Xenon

    Razer.Xenon Retired

    @GuppieGreensleektrend949 Please try to follow the steps on this link to fix the headset's disconnection issue. Also, allow us to further investigate this Synapse issue by sending me your MSinfo logs via PM.

    @pfussella Send me your ticket number. I can use it to review your interactions with our support team and take the necessary steps in sorting out your case.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >