Blackwidow Chroma wont work

Discussion in 'Razer Support' started by portalaeroFallow956, Nov 19, 2021.

Thread Status:
Not open for further replies.
  1. portalaeroFallow956

    portalaeroFallow956 New Member

    My Blackwidow chroma has served me well for years and yesterday I started to have some issues with the arrow keys and number pad acting up and inputting things when they weren't being pressed. I downloaded synapse 3.0 and used it to disable those keys so that the issue would hopefully be resolved. I ended up unplugging my keyboard that night and went to sleep and now today when I tried to lug it in again it just won't work. It doesn't light up or register any inputs. I tried to plug it in somewhere else but it didn't change anything and my other keyboard and my mouse work when using the same USB ports. I fear that it might be an electrical issue but I came here to see if there's anything else that I could possibly try to fix this issue.

    I tried to make a ticket but Blackwidow chroma is no longer supported and I couldn't find any driver updates anywhere. Any help I could get would be greatly appreciated.
     
  2. Razer.Xenon

    Razer.Xenon Retired

    Does the device still get detected on the Device Manager? First off, let's try cleaning your keyboard by following the guide on this page since a spec of dirt or dust build-up could cause your keyboard's switches to work abnormally. Then reinstall the device drivers by performing the steps outlined below:

    -Press Windows + S on your keyboard to open the Search bar.
    -Type in “Device Manager” and hit Enter.
    -Go to Keyboards
    -Right-click on the Razer device in question and select Uninstall device.
    -Go to Human Interface devices.
    -Right-click on the Razer device in question and select Uninstall device.
    -To completely uninstall the drivers, restart your computer.
    The drivers will automatically reinstall after your computer restarts.

    Should the issue persists, PM me the serial number of your device. I can use it to verify its model and look for other possible solutions.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >