Blade Advanced 2019 screen flickering when BT turn on/off or connecting usb devices

Discussion in 'Razer Support' started by dailyDarkSeaGreenvine429, Jun 28, 2019.

Thread Status:
Not open for further replies.
  1. I got a BLADE 15” (MID 2019) ADVANCED MODEL recently, the screen always flickering when I toggle Bluetooth on/off or connect an USB device. I tried to do an clean installation of Windows 10 and update to the newest 1903 version, however, the issue still persist.
    Also I noticed that this problem may related to Color Calibration, if I choose Blade.icm as system default profile, the issue described above occurs, while I choose sRGB IEC61966-2.1 or others icc files as default, the problem seems be sovled, but the display color also changed.
     
  2. Hi there,

    ran into the exact same issue (brand new Blade 15", OLED/4K, 2080 Adv.). Every wifi scan, BT causing flickering. Factory setup.

    Searched different forums and saw mention of out-of-date Intel drivers provided (via reddit), so I tried installing latest via:

    https://www.intel.com/content/www/us/en/support/intel-driver-support-assistant.html

    It updated my Bluetooth and WiFi drivers. After this, toggling bluetooth, scanning for wifi networks have stopped the screen flickering.

    Hope this helps you.

    Good luck!
     
    Razer.Speedcr0ss likes this.
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey guys! Thanks for posting to our Support board. And yes, updating your Intel Graphics driver for Razer Blade will surely help. Should the issue persists, feel free to send me a PM.
     
  4. Thanks for your help! I have updated the latest drivers according to your reply, but the issue still persists. Do you use RAZER's color profile blade.icm as default?
     
  5. Yes, I use the default / stock setup with the following changes: Updated Nvidia drivers, updated Intel drivers. ( no change to color profile )

    As a separate (not related to screen) note - I noticed continued disconnects from WiFi, which disappeared after separating the SSIDs for 2.4GHz and 5GHz on my end.
     
  6. One thing that may apply is removing the updated devices from device manager, doing a re-scan to make sure the new drivers are in fact applied. (as suggested in some of the other threads). I remember trying this at some point, so that may have been a part of the process.
     
  7. Adding another item that I ran into for flickering issues -

    ( taken from the other screen flicker thread, courtesy of the person who reported/had tried a fresh install ):
    • Disabled panel self-refresh and extend battery life for gaming from within the Intel HD Graphics Control Panel
    ---

    I was seeing intermittent (every 30m or so) flickering, but after disabling this (essentially, turning off all power saving profiles in Intel HD), what I would describe as a "color flicker" (same as going from non-full brightness to full brightness) hasn't been observed over the last 1-2 hrs.
     
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for posting this to our thread. Let's check if the screen flicker still happens to a different Windows User Account. I'll be waiting for your update via PM.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >