Blade early 2021 with WIFI disconnection on Battery and SSD showing half size

Discussion in 'Systems' started by diggum, Sep 16, 2022.

  1. diggum

    diggum New Member

    Hi guys , i have just been slack with this issue since new.

    my blade 15 ( a 10875H with 3070 and a QHD 240 purchased through retail brand ) has consistently disconnected on battery. More specifically, if i am running on battery, the wifi would disconnect randomly ,and particularly if say downloading an ISO ( or consistently large file say over 40MB

    the issue is not reproducible when running on AC. The WIFI adapter has been uninstalled and followed all the WIFI disconnecting FAQ on RAZER's website, to no avail. The latest drivers from Intel as recommended are on the laptop, window is fully updated to 17/09/2022.

    supplementally , i added another 970EVO plus 2TB as the secondary drive and she is not showing it to be 2TB but rather just 1TB. Samsung's own Magician software correctly recognizes it as such and windows is showing 2TB space./

    This laptop has been handled with kids gloves since new. the machine is so temperamental , that it would consistently ( thrice a week refuse to recognize the BW3 PRo and viper ultimate and thus cant be used. Only to have to manually uninstall and let the machine install the drivers. AS opposed to my work laptop a T450 running exactly the same OS is rock solid with the peripherals.
     

    Attached Files:

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >