Cannot install Synapse3

Discussion in 'Razer Support' started by LuciousBX, Jun 6, 2022.

Thread Status:
Not open for further replies.
  1. LuciousBX

    LuciousBX New Member

    Hi,

    I cannot install Synapse3 and it feels like i've tried everything

    The issue started with Synapse 3 needing an update, which it couldn't perform for some reason (Received error 145), so I decided to uninstall Synapse3 and install it again. I successfully uninstalled it, but when it came to installing it again, nothing happens when I run the installer.exe file.

    I've tried to:
    * Uninstall all Razer drivers
    *Disconnecting all my razer products
    *Deleted everything Razer in my folders & subfolders
    *Made sure i have the latest Windows update
    *Stopped ongoing Razer processes through task manager
    *Starting the installer as admin
    *Performed a sfc scan

    Now I see whenever I try to open the Synapse3 installer, it generates an error file from whenever I tried to start it. Pictured below.

    Running Win 11.
    upload_2022-6-6_14-8-17.png
     
    RazerBurra likes this.
  2. RazerBurra

    RazerBurra New Member

    I have exactly the same problem and have done exactly the same.
    Cortex will start but synapse does nothing.
     
  3. FiszPL

    FiszPL Well-Known Member VANGUARD

    What's in the err file? Can you open it with notepad for eg?
    Check if you have .NET 4.8 installed in your OS, also if you have Microsoft C++ installed - uninstall it.

    Try this tool: https://rzr.to/Tf53xj to remove all razer drivers/leftovers, then restart your PC, and after restart try to install Synapse again (as administrator).
     
  4. RazerBurra

    RazerBurra New Member

    I have found the problem. It appears that there is compatability issue with the latest AMD Win 11 drivers.
    In the device manager it always came up with an error involving AMD.
    When I rolled back to an older AMD driver all is good again.
    i don't know who is in the wrong AMD or Razer but rolling back has solved the problem for me and there is no big advantage in the latest AMD driver for me.
    Hope this helps others with the same issue.
     
    FiszPL likes this.
  5. LuciousBX

    LuciousBX New Member

    FiszPL likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >