Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Can't start Synapse 2.0. Crashes when I login.

Discussion in 'Razer Synapse' started by AlexanderDaGrt, Mar 25, 2020.

Thread Status:
Not open for further replies.
  1. AlexanderDaGrt

    AlexanderDaGrt New Member

    Can't get past the login screen. If I wait it out the login verification long enough it will eventually give an error saying I am not connected to the internet. Don't worry, I am connected.
     
    pancholr likes this.
  2. FiszPL

    FiszPL Well-Known Member

    Check antivirus / firewall? Maybe it's blocking synapse connection to the internets.
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Is this still the case? If so, shoot me a PM so I can help you further isolate the problem. I'll be moving this to the Support board for visibility.
     
    0V3R_K1LL and DRIFT_IT like this.
  4. bennettk

    bennettk New Member

    I'm also not able to start Synapse 2.0. After logging in it starts 'syncing with the Cloud' then crashes.
    I'm installing on a new Windows 10 PC and tried all the re-installation, running as Administrator, disabling firewall and creating a new account suggestions but it still crashes at the same point.
    My Razer Naga 2014 is not usable without it - mouse pointer is unresponsive or stuttering and jumpy at best.
     
  5. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Please PM me a screenshot of the error messages and a link to where you got the Synapse 2.0 installer. I'll take it from there.
     
    0V3R_K1LL and DRIFT_IT like this.
  6. Mebz023

    Mebz023 New Member

    I'm also having issues with Synapse 2.0. After I login, the app minimizes to the tray and I can not open it after. I close synapse 2 and login in, same thing. I've tried all the troubleshooting I can from restarting to googling and checking other forums of recent issues. It seems like there is an issue with the legacy system itself.
    Please advise, I cannot use my Orbweaver Chroma without it.
     
  7. bennettk

    bennettk New Member

    I downloaded Synapse 2.0 installer from the main razor site : razor.com/synapse-2
    There is no error message, so a screen shot won't help. The app just minimizes to the item tray after logging in.
     
  8. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @Mebz023 @bennettk Are you on moderated networks, and what OS are your computers running on? Have you tried running the app with administrator privileges?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >