Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Chroma Connect not detecting Devices

Discussion in 'Razer Support' started by Eloyball, Sep 1, 2020.

Thread Status:
Not open for further replies.
  1. Eloyball

    Eloyball New Member

    Hello, I've been trying to solve this issue for a while now. I own a Huntsman Elite keyboard and Naga Trinity mouse. One day whenever I used Chroma Connect the led lighting on my keyboard would freeze from time to time, so I tried uninstalling and reinstalling Razer Synapse 3.0, while deleting all Razer related files. It didn't work, so I tried uninstalling the drivers of my keyboard, then I also tried to factory reset my keyboard. However now my keyboard and mouse won't even be detected by Chroma Connect. Chroma Studio was detecting the keyboard and mouse but the chroma effect didn't work until I changed it a bit and saved it. Alexa is also able to change the chroma lighting, the only app that doesn't is Chroma Connect. I tried uninstalling and reinstalling only the app and then repairing Razer Synapse but still didn't work. Does anyone know how to fix this? I tried everything I could think of. Thank you
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >