Chroma connect not working with Overwatch?

Discussion in 'Razer Support' started by Aman_Exe, Jul 5, 2020.

Thread Status:
Not open for further replies.
  1. Aman_Exe

    Aman_Exe New Member

    I just bought "Razer Blackwidow Elite 2" days ago and downloaded Razer synapse 3. When I tried to play Overwatch and try out the chroma lightning on it (It looks cool C: ) then for some reason it didn't work. It works fine on PTR version but on Live version it's not working. I have tried reinstalling the drivers and the synapse 3. restarted pc multiple times (after uninstalling the stuff and drivers) but no luck. I googled the problem and tried some of the solutions that I found, but nothing has worked so far :C

    I also tried warframe and it worked fine with that as well. Its just Overwatch live version that I have problem with.
    Please help :/
     
  2. RaszeIceburn

    RaszeIceburn New Member

    I'm having the same problem with this game. Chroma works fine with Doom and Diablo III for me.
     
  3. OnyxDog

    OnyxDog New Member

    Same. Diablo 3 was fine here as well. Very frustrating trying all of the solutions online but nothing worked.
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    We have received reports of performance issues and crashes, so Chroma Integration for OW has been temporarily disabled. Do keep an eye out for a hotfix.
     
    OnyxDog likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >