Crackling sound after windows update 20H2

Discussion in 'Razer Synapse' started by placeventureVividRed748, Nov 15, 2020.

  1. Hi, so I saw some people with this problem. When I use win build 1909, razer surround audio controller was OK. But when was update to version 2004 there was crackling noise, and it was useless. So I waited few moths for some fix, and still used the 1909 build. But now windows automatically downloaded build 20H2 and there is again problem with crackling sound. Anybody know how to fix it, or will be the fix update for synapse or windows or something? Thanks.
     
  2. FMac96

    FMac96 New Member

    Yeah i have the same problem, I'm still using the 1909 build because the surround pro is amazing for FPS like CSGO and Valorant like no other, this is the only reason why i'm staying on this build but after months there is no solution, can't find anything that can solve this problem :frown_:. I hope that at some point Synapse will be updated and can solve this problem :/
     
  3. I fixed it, nwo using 20H2 with Synapse, but you have to download and install Bluestacks (android emulator), and just install it, launch it, and have it turned on in the backround and problem is away. Its funny that other programs fixing razer problems, cause razer dont know make update
     
    Burntpinz and llen_llen like this.
  4. JulianKapa

    JulianKapa Well-Known Member

    I don't think I get it - you're running Bluestacks but not any app on it? That seems strange that it gets rid of the problem.
     
  5. yeah, just install and run Bluestacks and thats it.
     
  6. burbigo1

    burbigo1 New Member

    Last edited: Dec 18, 2020
  7. yes
     
  8. FMac96

    FMac96 New Member

    Really?, that's a possible solution?, i am going to try it :), brb
     
  9. sharpDeepRuby407

    sharpDeepRuby407 New Member

    which surround sound you are using?
     
  10. I am using Razer Synapse 2.21
     
  11. ItzCerberusFN

    ItzCerberusFN New Member

    Ye same here dont know what the actualy reason is. i Purchased my headset today it self and the surround sound gives a crackling sound
     
  12. llen_llen

    llen_llen New Member

    The weirdest thing is that it actually works. I have no idea and it sounds much like car allergic to vanilla ice cream, but I think I'll keep it this way until it got updated. Thank you very much.
     
  13. Spaceman316

    Spaceman316 New Member

    Hi, recently updated to 20H2. I have the same problem. Am using Razer elektra v2 with surround pro. However i tried other surround software which is Boom3D. It fix the problem with almost the same quality as Razer surround pro. maybe you guys can try it out.
     
  14. CaptWalker

    CaptWalker New Member

    just tested it bluestacks fixes the problem only god and a avid programmer know what is going on
     
  15. WoonooW

    WoonooW New Member

    Are we supposed to live with the bluestacks workaround or is any support gonna give us an update on this?
     
  16. JulianKapa

    JulianKapa Well-Known Member

    This isn't the support category.
     
  17. WoonooW

    WoonooW New Member

    What I mean is, will this problem be fixed, if so will any support member notify us?

    Even if it isn't the support category then what are we supposed to do? Just live with the issue? Accept that it isn't going to be fixed?
     
  18. JulianKapa

    JulianKapa Well-Known Member

    Contacting someone who can do something about it/pass on the message, or post where the team will see it.
     
    WoonooW likes this.
  19. pedr0markx

    pedr0markx New Member

    Saw somewhere about the "DPC Latency checker" as well, it did worked for me, just 300kb better than having bluestacks open I believe
     
    natan95 and geospaceship788 like this.
  20. Buckown

    Buckown New Member

    I just tried "DPC Latency checker" and I have no more crackles, thank you!
    Hope Razer fixes it someday...
     
    natan95 likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >