Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Having issues with synapse and need some help

Discussion in 'Razer Support' started by JaxyBoi, Mar 25, 2019.

Thread Status:
Not open for further replies.
  1. JaxyBoi

    JaxyBoi New Member

    I've tried both synapse 2.0 and 3.0, neither of which allow me to log in to access settings for my devices. I can log in to the website just fine with my razer id, it's just synapse giving me issues. I've tried multiple pc restarts, fresh installations and repairs of synapse, and customer support live chat was 3 consecutive times useless. so I suppose I'm here seeking anybody who could help outside of those basic troubleshoot options i've already done multiple times.

    [​IMG]

    https://imgur.com/a/G7RQolw

    This would be the persistent error message i've been getting the past 3 days of trying. "Oh snap! Something went wrong just now please try again."
     
  2. FatKidWanderer

    FatKidWanderer Well-Known Member

    Can you try to check for an update of your Razer Synapse? Try to launch Razer Central. To open Razer Central, expand the system tray by clicking the arrow found on the lower right side of your desktop. Click on Check for Updates. Synapse will check for updates. If there is a new update, click Update to install.

    Let us know about the results.
     
  3. JaxyBoi

    JaxyBoi New Member

    Sadly when I do this it is revealed to be fully up to date, and I get the same results when i attempt to log in.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >