Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[HELP] Razer Blade Stealth Battery Not Charging

Discussion in 'Razer Support' started by MothySays, Oct 12, 2020.

Thread Status:
Not open for further replies.
  1. MothySays

    MothySays New Member

    Hello! I have the 2017 Razer Blade Stealth i7 7500U. I've had this laptop for a few years now I and I ran into an issue with they battery less then a year into ownership. However, I had stopped using it my senior year because I was unable to to use the laptop off the charger.

    The laptop works perfectly fine when its plugged in, though the battery indicator on the task bar shows that it is plugged in but the battery shows and "x" on it. I've seen the message say everything including "Plugged in and charging", "Plugged in not charging", "Battery not dectected". I've tried installing every update both windows, and on the devices updates page. I've tried to reinstall the device driver for the battery and still not fixing the issue. When I unplug the laptop it last for about 15 seconds before cutting off. Even if i leave it plugged in to charge for a while i still get under 20 seconds of battery life unplugged.

    Kinda at witts end here.. Any help??
     

    Attached Files:

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >