Huntsmen Elite V2 Spamming Issue

Discussion in 'Keyboards' started by Brutalbipedal, Jul 21, 2021.

Thread Status:
Not open for further replies.
  1. Brutalbipedal

    Brutalbipedal New Member

    Hi all,

    I am one of many having issues with keys spamming, I've done a complete clean re-install of Synapse and this made no difference. I've air blasted the keys also and still it happens every few days.

    However the keyboard is the first I've had where it has a USB 3.0 and a USB C connector. The USB C has an adapter so it can be plugged into a USB 3.0 port. Should this make any difference if I use the USB C connector natively or should I use the adapter so it is USB 3.0?

    I have a ticket open for this also with support and they want to replace the keyboard...

    Thanks
     
  2. JaydontheThing

    JaydontheThing New Member

    First of all I think you mean the Huntsman V2 analog, but yea it looks very much like the Elite, so I’ll give you that one.

    Secondly, I am anothing person with this issue. Sometimes the keys stop working completely or the volume slider and media keys stop working. The main problem though is the Key Spamming. I have tried plugging it into different ports, reinstalling and loads of other things.

    I found out that Razer has already fixed the issue on their previous keyboards if you look at the Firmware updates section on their website, but just not for this keyboard yet. I’m hoping they tell me cause I’ve asked.

    For now I would use your keyboard without Synapse.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >