Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

I can't login to razer apps.

Discussion in 'Razer Support' started by Kondzik_B, Jul 15, 2019.

Thread Status:
Not open for further replies.
  1. Kondzik_B

    Kondzik_B New Member

    I can't login to my razer apps, but i can log in to razer web site.
     
  2. Spiff2000

    Spiff2000 New Member

    Same problem here.

    Error message:
    There was an unexpected error. Please reload the page and try again.

    I have tried:
    1. Going back to the log in page and try again
    2. Resetting my password
    3. Exiting all Razer software and start it again.
    4. Restarting my computer.
    5. Reinstalling the software.
    6. Wating for fix.... This step worked! :D

    It wasn't that bad, 1 hour from people reporting it to it was fixed. Nice work!
     
    Last edited: Jul 15, 2019
  3. Nazareim

    Nazareim New Member

    Same problem, re-installing Razer software doesn't help
     
  4. Topshottax11

    Topshottax11 New Member

    Same issue
     
  5. liquidmojo

    liquidmojo New Member

    same issue here. this is a freshly built pc and windows 10 install. everything has worked fine for weeks, until this morning. I am now unable to login to Razer Central. my credentials are fine, as I am able to login to the website/forum. suggestions welcome. a full uninstall and reinstall would be ridiculous, so I am hoping for a more thoughtful suggestion....

    this "feels" like an issue with Razer Central authentication server and not with my client, but... who knows at this point
     
  6. Spiff2000

    Spiff2000 New Member


    Looks like they have a problem with the log in service for the app. They should just tell people to stop wasting time by uninstalling software and stuff. And just say they are working on it right now.
     
    scestes likes this.
  7. cassen999

    cassen999 New Member

    I am having the same issue as of this morning as well (7/15/19). I reset my password, uninstalled and reinstalled synapse and nothing. I am also able to log into the website as well, just not the app.
     
  8. lily9000

    lily9000 New Member

    Same problem here, synapse 3 needs offline mode like synapse2. This is a joke. Cant use Taratarus V2 without being logged in. Synapse 2 doesn't see tartarus v2.
     
  9. Spiff2000

    Spiff2000 New Member

    Looks like it is working again now! :D
     
  10. liquidmojo

    liquidmojo New Member

    it magically resolved itself, with no action on my part.... sketchy
     
  11. lily9000

    lily9000 New Member

    Yup - same here, syncing now ...
     
  12. lily9000

    lily9000 New Member

    Just wondering is there anyway to save the modified keys to the tartarus v2 so they just do the keystrokes without needing to be logged in?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >