Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Issues with Bios Update on 2020 Razer Blade 15 Advanced

Discussion in 'Razer Support' started by cv07nguyend, Sep 29, 2020.

Thread Status:
Not open for further replies.
  1. cv07nguyend

    cv07nguyend New Member

    Just tried to update my 2020 Razer Blade 15 Advanced to the latest bios 1.04 I believe and I got bsod about midway through the update. My laptop then restarted and the screen is black with keyboard lighting up and power light lighting green and cycling. I've tried everything from ram removal, ssd removal, to cmos battery removal with no luck. Please someone help with this?

    I tried calling the support line and using online chat but both are unavailable.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    It is highly likely that the BIOS has been bricked. There is no room for us to troubleshoot if the laptop won't even boot anymore. You will have to send it in for repair. Please send me the serial number and proof of purchase so I can submit a warranty claim on your behalf.

    *Locking thread to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >