Issues with JungleCat so far

Discussion in 'Console Peripherals' started by MullenLive, Nov 6, 2019 at 3:57 PM.

  1. MullenLive

    MullenLive New Member

    So far I have 3 issues with my new JungleCat.

    1) Charging: according to the manual, the LED should be red when charging, and green when charged. What happened to mine is when I plug-in USB-C charge cable, I only see green light for few seconds, then turned off. I never see red light. Is that expected?
    Sorry I haven't checked if the controller really charged (LED issue) or not charged at all. Tried different charger / cables so far.

    2) When I connect my RP1 with Razer Junglecat L, the R controller lost connection every 30 seconds (exactly 30 seconds). It will recover after about 2 seconds, but I could lose the game during this 2 seconds. It's system wise issue, means I see the controller disappear and reappear in the settings. The reason I says the issue is R controller is because L controller is almost steady green (may blink but really fast so hard to tell), but R controller will blink in blue during that 2 seconds.
    I don't see the issue when connect to PC. It seems that it's good when connect with Razer Junglecat R, but unfortunately I have a game that only works with L for now. My RP1 is already pied, so it's possible that the buggy pie RP1 is the one to blame, but still... (I will try to see if I could test on other Android phone).

    3) In the Razer gamepad app, if the game is "Compatible", when launch the game with controller connected, it shows the options to customize the input. However, if the game is manually added, such option doesn't show but just directly launch the game (can't customized anyway). From the manual I think the option is supposed to supports any game, so I think it's a bug of Razer gamepad app.
     
  2. xRuhRohx

    xRuhRohx Member

    Mine has the same connectivity issue. I tried connecting to two other phones, and had absolutely zero issues.
    Although no matter which I connect my RP2 to, R or L, the left one is the one that disconnects and reconnects.
    I am thinking about returning it and getting the Raiju Mobile.
     
  3. xRuhRohx

    xRuhRohx Member

    I went ahead an initiated a return on my Junglecat, but as soon as I get home from work I want to try it again but uninstall the app from my phone first. The two devices I tried the JC with, did not have the app. So since you are having the same issue as me, see if uninstalling the app works to maintain connectivity. That might help us narrow down the cause.
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for posting your Razer Junglecat's concern here. This needs to be investigated. Please send me a PM. Let's continue from there.
     
  5. xRuhRohx

    xRuhRohx Member

    Also as a tip for anyone not having connectivity issues, if you turn thumbstick sensitivity down, some games that allow you to map inside the game, will not recognize the thumbstick.

    Dead Trigger 2 prompts you to map inside the game when it detects the controller. The right thumbstick was way to sensitive so I turned it down. Due to connectivity issues, the game detected the other side of the controller and asked me to map again. I could not set any control using the right thumbstick until I went back into the controller app an turned the sensitivity back up.
     
  6. xRuhRohx

    xRuhRohx Member

    Ok I can confirm that the app is not the problem.
    I uninstalled the app and rebooted my phone and still have the same issue.
     
  7. MullenLive

    MullenLive New Member

    Just update. My R connectivity issue get solved by itself. All I did was charging it for long time. I don't know if the 30 second disconnection is a weird way to let me know the battery is low, but I actually checked batter in the app and it was good (though I don't know percentage). It's also weird why it only happens when connected to phone. I think the only way to know more is using the controller until the issue happens again.
    Btw, for 1), I could confirm the controller can get charged. It's only the LED doesn't work properly. Am I the only one who has the issue?
     
  8. xRuhRohx

    xRuhRohx Member

    Well I charged both of mine and still had the issue.
    The controllers work flawlessly with other phones I have tried.
    It seems the issue is only when using with a Razer phone.
     
  9. MullenLive

    MullenLive New Member

    Glad to hear you tested with other phones. Then I think it's possible RP1's issue. Just a wild guess, it's possible that actually RP1 lost connection with L for very short time that L doesn't change LED status, but as a result R also lose connection and take much longer time to recover.

    Btw, do you see LED work correctly when charging?
     
  10. Gabzilla_

    Gabzilla_ New Member

    Apart from these problems would you guys reccomend the product, I am thinking of ordering one.
     
  11. xRuhRohx

    xRuhRohx Member

    I honestly didn't pay attention to the LED when charging.
    Also I think it is the connection with RP1 and RP2. It is something in how the RP talks to the JC.


    I highly recommend the Junglecat, if you can deal with buying a product you can't really use and waiting for Razer to fix the issue. If I only had the connectivity issue, I would have probably kept it and waited for a fix. But most of the games I play are not supported, but an Xbox controller works great and works with 90% of the games I play so I plan on getting the Raiju mobile.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >