Keyboard Key Not Working Properly

Discussion in 'Razer Support' started by jeremyvandermolen, Aug 26, 2019.

  1. jeremyvandermolen

    jeremyvandermolen New Member

    I have a Razer Cynosa Chroma and recently when I tried to type 7 it is typing 67. When I use the key it is using both the 6 and 7 keys simultaneously. (This is not happening when I use the 7 from the far right of the keyboard, just the one on top of the letters). I am not sure what the problem is, if someone could help that would be great.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Have you tried logging out from your Razer Synapse account and see if the issue still persists? Please connect your keyboard to a different USB port or to a different PC without Razer Synapse installed and see how it goes.
     
  3. Sippenforscher

    Sippenforscher New Member

    Hello! I've got the same problem, but with me its the "y" key. Most of the time, if I type "y" a "yx" appears. Sometimes its only a "y" and from time to time theres even an "x" appearing.
    I think I tried everything: differnt USB ports, with/without installing Synapse, uninstalling the drivers and only using "legacy" (?) drivers, different PCs with different versions of Windows... what else can I do?
     
  4. Vin_Ikra

    Vin_Ikra New Member

    I have a similar issue but for me its with the 1 and 8 keys.
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! If the issue still exists after performing the isolate steps above, please send me a PM. Let's continue from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >