Keys not working on Razer Huntsman

Discussion in 'Razer Support' started by MissNewDream, Aug 9, 2020.

Thread Status:
Not open for further replies.
  1. MissNewDream

    MissNewDream New Member

    Hello!
    I have a Razer Huntsman since December and everything was perfectly fine but since a couple of days I realize I wasn't able to Print screen with the key anymore.
    I tried it again today and I also tried the other 2 keys next to it (scr lk and pause break) and it seems like scr lk isn't working aswell. The pause break is working most of the time but sometimes I have to press it multiple times for it to work.
    Could it be link to the last update or not?
    Is there a way to fix this or is it just broken or idk?
    (Just to be sure I'm talking about those 3 keys keyboard.png )

    Edit : After trying others things, I realize that all the top row of my keyboard isn't working properly. Even if I slightly touched them, some keys act like I pressed them a lot and few of them (F9, F11, F12, Prt scr & scr lk) aren't working at all anymore.
     
    Last edited: Aug 9, 2020
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >