Multiple machines support ?

Discussion in 'Razer Synapse' started by lenam701, Nov 3, 2021.

  1. lenam701

    lenam701 New Member

    As much as I laud the quality of Razer hardware, I cannot say as much about the software (and I'm a software engineer, to top it off). I've always like Razer's hardware for more than a decade now. For the past 8 years, I was using Logitech only because I had access to a significant discount (-35%) from my job even if I preferred Razer. Ironically, it was the software for the Logitech G815 keyboard that drove me nuts and got me saying "F*** it, I'm going all Razer".

    But now Synapse is being a total pain in the back...

    I am certainly privileged to be able to say that I have 2 machines (my desktop and my newly acquired Razer Blade 14). However, I am APPALLED (to remain polite) at the software support, especially regarding the configuration across machines.

    I bought the Razer Blade 14 so that I could game on the go when I travelling, especially visiting my family. But now, I am running into this problem with Synapse: any configuration change I make on one machine regarding profiles, in particular Chroma Studio, basically ruins it for the other. I really have no intention to reconfigure my Chroma setup every time I turn on a machine.
    I tried having separate profiles per machine (e.g: Age of Empires and Age of Empires (Blade) profiles) but then the assignments get messed up since AoE is installed on both machines. Assigning the game AoE to the profile AoE (Blade) on the laptop replicates the same for my desktop, which obviously makes no sense, and vice versa. On the other hand, having only one AoE profile has one machine well configured while the other one goes completely dark.

    Has anyone else encountered a similar issue ?
     
    FiszPL likes this.
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    Yup, have similar issue.
    Using some Razer peripherals in work, laptop has Synapse installed, I've created a "home" and "office" profile, but sometimes when I run my PC at home, I see some new profile created like Home(1), with some settings messed.
    It's totally random for me, so it's hard to reproduce the problem.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >