Nabu watch forged edition is not syncing with the nabu android app

Discussion in 'Razer Support' started by jakw0lf, Mar 22, 2019.

Thread Status:
Not open for further replies.
  1. jakw0lf

    jakw0lf Well-Known Member

    Hey guys,

    So today i got my Razer Nabu watch forged edition. Unboxed it, charged it and installed the Nabu app on my phone (One Plus 6T | Android version: 9).

    After installing the Nabu app i gave all the permissions and switched on the location and bluetooth post which tried adding the Nabu watch from the app home screen.

    The watch gets found/detected on the initial screen, long pressed which showed me the 4 digit number and entered the same in the app. Then it connects and starts the "syncing" screen. It goes on showing the syncing message for almost 30s - 60s and throws message "syncing failed, error".

    I tried syncing it multiple times without no luck of getting any further.

    Also tried,
    - uninstalling and reinstalling the app
    - re-logging in to the app
    - gave the permissions again
    - switched off/on the location and bluetooth

    Not getting any further, can somebody help me please to get this sorted.

    Thanks in advance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >