Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

NARI Battery is poor - probably due to synapse

Discussion in 'Razer Support' started by Crocchiaossa, Dec 12, 2019.

Thread Status:
Not open for further replies.
  1. Crocchiaossa

    Crocchiaossa New Member

    A couple of days ago i opened a tiket on razer support because after something like an hour my razer nari show low battery, even after a full charge.

    Eric, God bless that guy, asked me to make some tests, like changing usb cable and ports, not charging overnight, trying to discharge the headphones, etc.

    I tried to discharge the batteries by leaving them playing some music, for some hours in the morning, then evening, etc. Here's what happened:

    Synapse said my batteries were discharged, since they were still playing, i left them on, but while i was browsing synapse, the program crashed (the headphones were still playing though); when i re-executed it i saw the battery icon not at 100%, but a bit less. So i left them on playing again. I did not turn them off, i left them playing some music. After a couple of hours, again, it beeped, saying the batteries were drained. I terminated synapse via task manager, and the batteries were at around 80%, again. I kept on using them.

    On the third day, they died, for real. They were discharged even after termination and re-execution of synapse. But, when i plugged the charger, synapse still showed them as discharged, not showing the charging icon. I had to terminate again synapse(always via task manager), and only when i executed the program again it showed me it was charging.

    After these days, i started thinking it is a software issue (or a conflict of some sort), and since i have uninstalled synapse and reinstalled it, I have no older release backup.

    So, i'm here to ask you guys: where can i find the older releases of synapse? The older ones, with razer softminer, that were available in April, worked fine and showed me the battery percentage, a thing that the latest version does not.
     
    Last edited by a moderator: Dec 22, 2019
  2. Crocchiaossa

    Crocchiaossa New Member

    UPDATE
    I managed to somewhat reproduce the problem:
    I reinstalled synapse (3.4.1112111915), and i noticed immediately that when i connected the headphones, it updated the battery status only when i was switching between audio tabs like "sound", "mixer", "equalizer" etc. If i left the "sound" page opened and plugged the usb charger, it would not show as "charging", though, if i switched tab, it would update.

    So I left the headphones on, while playing some music so they would not turn off. After some time, they "discharged". When i tried to change tab, that's what happened.
    crash.jpg
    I had to press OK on 10 of these windows, synapse crashed, but not razer central. When i re executed synapse, everything was working again and, obviously, my headphones were still with a lot of energy
     
    Last edited: Dec 14, 2019
  3. Crocchiaossa

    Crocchiaossa New Member

    UPDATE - SOLVED
    I somewhat managed to solve the issue by completely uninstalling the software and the drivers. With the usb repeater plugged in I went in safe mode, and uninstalled the drivers in device manager selecting "completely remove software from this computer", forcing it to delete the driver files from your hard drive - repeating this step for every synapse driver.

    When i re-installed, i wasn't able to reproduce the problem, so i can suppose the problem is solved
     
    Last edited: Dec 21, 2019
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >