Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Nari Ultimate Mic Issue fixed

Discussion in 'Audio' started by Asada_Sinon, Nov 22, 2018.

Tags:
  1. Zulucrit

    Zulucrit New Member

    This is what worked for me:
    I have Realtek HD Audio Manager, and it detected the Nari as one device instead of two.
    So the headphone audio would work, but the microphone would not pick up AT ALL.
    What I did was open the Realtek HD Audio Manager, and I went to "Device Advanced Settings" (The little cogwheel on the top right corner) And checked the boxes that said "Make front and rear output devices playback two different audio streams simultaneously" and "Separate all input jacks as independent input devices."

    This issue bothered me so much that I was considering returning them, so I wanted to share in case someone else has the same problem with Realtek HD Audio Manager and the Razer Nari.
     
  2. Fuzms

    Fuzms Active Member

    Thanks for the feedback, none of these things worked for me. still no mic.
     
    XXlolplXX likes this.
  3. 0V3R_K1LL

    0V3R_K1LL Well-Known Member VANGUARD

    If the mic only messes up in wireless mode it might be a firmware update, you can contact Razer support for the file. But do check if it works correctly in wired mode, maybe try it with some smart phone just so you dont have any drivers interfering.
     
    DRIFT_IT and XXlolplXX like this.
  4. Fuzms

    Fuzms Active Member

    Good call, will look into.
     
  5. markdragich

    markdragich New Member

    me 2
     
  6. Fuzms

    Fuzms Active Member

    For me, a firmware update solved my entire problem. Had to email tech support to get firmware. V14r4 is my current firmware.
     
    jerovick likes this.
  7. XDHardstyleFun

    XDHardstyleFun New Member

    I've still have the issue with the echo in chat, at pc or console. I've tried everything, and not a thing will work.. What to do?
     
  8. netanelmagz

    netanelmagz New Member

    same problem .-. why the hell this problem exist for so long i have no idea how to fix it
     
  9. XDHardstyleFun

    XDHardstyleFun New Member

    I did write to the support, and the only Thing they gave me was some easy troubleshoting.. Like have to tired diffrent cables, have you tried update synapse.. All the main Thing you will do if something not works proberly. But this didn't help at all. Every time i spoke om chat on xbox one, there was an echo in the mic, that my friends could hear everytime i spoke or they talked, real fustrating problem. I didn't find a resulotion so I've returned the headset to the store and got ny money back.
     
  10. uncle_farkus

    uncle_farkus New Member

    Yikes just got my ultimate with my Blade 15 and can’t get mic to work in discord. Guess this thread tells me I should return it
     
  11. BlackFireDragon

    BlackFireDragon Well-Known Member

    First cheack if you can on another pc if the issue also appear if not you can try to remove all razer softwere from pc then remove razer folders in appdata and programfiles then go to windows device menager and remove headset reboot pc and download new freash installer for synapse 3. Install softwere and connect headset everything should configure next you can cheack mic tab in synapse to make sure is on and go to windows sound device menager and select recording devices tab and set there mic for nari as default device next thing is click properthies on nari mic and go to last tab where you can change mic recording quality and set from crap to cd or dvd quality. When you do everything reboot pc and cheack if everything is working fine.
     
  12. eduardo118

    eduardo118 New Member

    same here, everyone can hear what is playing on my pc in the discord
     
  13. LordRavenII

    LordRavenII New Member

    I have the same problem with my newly bought Razer Nari. Everybody on my discord channel can hear everything that’s playing on my pc. I have tried reinstalling the drivers, reinstalling synapse 3 and discord. I have tried plugging it to different USB slots, tweaked the settings.

    Anyone knows a fix? I’m considering getting a refund if I don’t get this fixed.
     
    Albanianweeb likes this.
  14. Ludeyz

    Ludeyz New Member

    just got my nari headsets and i got no microphone input , any assistance please , i have tried basically everything what was on the forum and still got no where.
     
  15. ImaWIN

    ImaWIN New Member

    I have always been an avid fan of Razer but I think I am done with them. I bought a Razer Nari Ultimate about 6 months ago and now I am getting complaints that I sound like a robot. I've tried everything in this thread to no avail. I am sick and tired of crap Razer products. I spent like 200 bucks on this damn headset. I shouldn't have to spend weeks troubleshooting it.... I plug in a 4 year old Corsair headset and right away everything just works like it should.

    Yours Truly,
    A fed up customer
     
  16. rolts9991

    rolts9991 New Member

  17. XXL258

    XXL258 New Member

    I have exactly the same problem, it's shit for 200 euros
    :wink_::wink_::wink_:
    last product since razer never again
     
  18. ChantalvdWal

    ChantalvdWal New Member

    I will try the firmware update, but I had the same issues with my Logitech headset last week, so it doesn't seem to be a Razer issue
     
  19. xARACHN1D

    xARACHN1D Well-Known Member

    What in the everloving Hell is your PFP?
     
  20. Esventrex

    Esventrex New Member

    Hi everyone, this may be the solution for some people, in my case i completely forgot that I had the microphone disabled for Windows applications, check inside the privacy settings of the microphone if it is active.

     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >