Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

P and ' keys not responding correctly

Discussion in 'Keyboards' started by technoLicoricesigns611, Nov 11, 2020.

  1. I've had my Razer Cynosa Chroma keyboard for about 5 months, and just a few days ago I noticed that whenever I press the (P) key, it also triggers the ([) key, however when I press the ([) key, it doesn't trigger the (P) the same goes for the (') key, except it triggers the ; key. I tried re-mapping the keys back to their default settings to see if it was a keybind issue, but that didn't fix it, so i'm not sure what to do. I can delete the characters, but it's getting really annoying to type. Any help is ap[p[reciated!

    :"Here;'s an examp[le:"
     
    pancholr likes this.
  2. FiszPL

    FiszPL Well-Known Member

    Does it do the same on other PC? Have you tried to blow some air near the P key to remove any dust etc?
     
  3. timrhanson

    timrhanson New Member

    I'm also having similar issue with my Black Widow Elite, but triggers multiple key strokes (except for the P) I even tried replace the switch and it's still doing it. No Macros or anything loaded.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >