Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Raptor 27 USB-C not working

Discussion in 'Razer Support' started by PersonSuit, Apr 12, 2020.

  1. PersonSuit

    PersonSuit Member

    I just got the Raptor 27 and so far it is really nice. However, the USB-C is not working. If I connect it to my PC, video never shows on the screen though Synapse will see it. I can change my chroma settings just fine with Synapse so I know its communicating to an extent but no Video. I have tried with a PC, MacBook Pro and an iPad and none of them will show video. I even tried another USC-C cable and factory resetting but it still did not work. HDMI and Display port do work without issue. Is there anyway I can fix this or did I get a defective unit?
     
    Last edited: Apr 13, 2020
  2. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there@ Thanks for sharing your concern here. Please send me a PM together with your device serial number and a video showing the issue. Let' continue from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >