Razer Basilisk Ultimate Won't Charge

Discussion in 'Razer Support' started by Xenosous, Mar 28, 2022.

Thread Status:
Not open for further replies.
  1. Xenosous

    Xenosous New Member

    So as the title says my Basilisk Ultimate will not charge either through the charging dock or directly connected via the USB cable. The things I have tried that didn't work:
    • Cleaning the contacts on the dock and mouse
    • Reinstalling Razer Synapse
    • Plugging the mouse directly into my computer
    • Switching the cable between all available USB ports on my computer
    • Turning the mouse off while it charges
    In conclusion, I have tried every solution I have found and nothing has worked so far. Is there something I missed or at this point does it need to be sent into Razer?
     
  2. Razer.JaqenHgar

    Razer.JaqenHgar Retired

    I appreciate that you initiated performing some troubleshooting steps on your own. For now, let us rule out some software troubleshooting before routing to RMA options. Please send me a PM with your device's serial number to seek a firmware update that may fix this issue.

    *Thread locked to curb conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >