Razer BlackShark V2X detection with Synapse V3.

Discussion in 'Razer Support' started by Ocelooh, Jun 24, 2021.

Thread Status:
Not open for further replies.
  1. Ocelooh

    Ocelooh New Member

    Hello Razer community!
    I got my headset yesterday, and today I tried to install Synapse (V3). But the app doesn't detect my headset. I tried to unistall/reinstalled the app, restarting my PC and repairing the app but anything works. I think it's because on my PC, the output device is "Realtek(R) Audio" and not "BlackShark V2 X". But how can I fix that? Should I remove the drivers?

    (Sry for my bad english, I'm french)
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Are you referring to this device? Please be aware that the Razer Synapse 3.0 only detects those devices with USB connections. Feel free to send me a PM including your device's serial number as I need to check its details. Let's continue our conversation from there.
     
    Ocelooh likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >