Razer Blackwidow Chroma V2 - Left shift key issue.

Discussion in 'Razer Support' started by ShogunStu, May 20, 2019.

  1. ShogunStu

    ShogunStu New Member

    Hello, I've a Razer Blackwidow Chroma V2, which I've used for 3 months with no problems until this morning. For some reason the left shift key won't shift + select a letter for capitalization. Its the same with say selecting the #1 key for an exclamation mark. Another example would be shift + A to select all of this text - that doesn't work either.I hope I've explained that right. Funny enough, the right shift key works fine. I've been using Synapses 3. I've tried many fixes including;

    1. Changing the key from default, to disabling it and then re-enabling it.
    2. Reinstalling Synapses.
    3. Disabling the pass-through USB.
    4. Disconnecting and reconnecting the keyboard after a system reset.
    5. Deleting and resetting keyboard profile to default.

    So I'm unsure what else to do as none of the fixes I could find online seem to solve the problem. I don't own another PC to check the system. Any help would be greatly appreciated as I do a lot of writing and kind of use the left shift key for using capitals etc.
     
    Last edited: May 20, 2019
  2. Razer.Lauriat

    Razer.Lauriat Title: Entitled Staff Member

    Hey! This could be a hardware issue. Would you mind sharing a video of this? Please send it to me via PM and make sure to include the link to this thread as well. I'll be waiting. :smile_:
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >