Razer Blackwidow X Chroma Button Issues

Discussion in 'Razer Support' started by Happyfeet1999, Jan 14, 2019.

Thread Status:
Not open for further replies.
  1. Happyfeet1999

    Happyfeet1999 New Member

    Dear Razer,

    Got this blackwidow x chroma keyboard for Christmas gift. Guess what? It is causing so much frustration due to "W" and "S" not working properly sometime. Sometime it is working ok. THIS IS SO FRUSTRATING.
    This is a gaming keyboard and it is making me giving gaming altogether.
    Well done Razer!!!!

    Just try out for few hours and i feel like breaking it. There is not proof of receipt because it a gift from friend. It cost $200.....fucking hell. Damn lousy keyboard. First time using mechanical keyboard and it such a bad experience. Really want to throw Razer keyobard out of my window!!!!
     
  2. Happyfeet1999

    Happyfeet1999 New Member

    This is my first ever Razer product and it is causing me so much frustration. Unable to get receipt from my friend because her father is in ICU, dont want to trouble her over this stupid issue. Dont ever buy Razer product!!!
    Check ith internet (see my typo error??? "W" not working).....so many complaint about its buttons problem.
    Cost a bomb yet it cant compare to logitech membrane keyboard which cost only $30.
     
  3. Happyfeet1999

    Happyfeet1999 New Member

    you are going to post this message correct?
    "Have you tried unplugging and replugging it to a different USB port? Also, have you tried it on another computer?"
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @Happyfeet1999 so much anger in one thread but I totally understand where you are coming from. It sounds like you already reached out to our Support Team and is stuck because of the proof of purchase requirement. Do send me a PM with your case number if you already have one and I'll see what I can do to help you out. Consider the thread locked though as it is in violation of the House Rules.

     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >