Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Blade Stealth 2016 not working with Razer Core X Chroma

Discussion in 'Razer Support' started by CrookedOwl, Aug 19, 2020.

  1. CrookedOwl

    CrookedOwl New Member

    I'm having an extremely frustrating issue. I bought a Core X Chroma new on amazon, and it came today. I intend to use it on a family trip as to avoid lugging my main rig around for 300 miles. I have a Razer Blade Stealth 2016, model RZ09-0196. I am using an MSI RTX 2070 Gaming OC 11GB as the gpu. The Thunderbolt Controller on this system is listed as the 159D variant.

    Upon plugging in, I got an error. Thunderbolt controller failed and needs a firmware update. The Core system is unrecognized, and the Thunderbolt Control Center shows a blank window with no options.

    I have:
    Reinstalled Windows.
    Updated windows fully.
    Updated BIOS to most recent version.
    Updated Thunderbolt firmware, I tried the versions on Intel's site for the generic drivers, and I have also tried every Thunderbolt driver that is used on every other model of Razer Laptop. The current driver i have installed is 1.41.769.0 (11/20/2019). The version I started with was 15.3.19.1, (2016) which is listed as the most recent version available for download for my specific model. I find very frustrating that a newer version than one from 4 years ago is not supplied or listed on the support site.

    I have tried contacting razer support directly, however as my razer blade stealth is 4 years old and out of warranty, they will not help me. I will not register my Core X Chroma until I know it works, as I am intending on returning it since it refuses to work.

    After installing the 2019 version of the driver, I no longer get the error in a pop up but it appears in the control center instead. However the Core X Chroma does not show up in Thunderbolt Control Center, it is still just a blank screen, other than the error. The GPU does not show up in the Device Manager either. The only thing that does show up is a "Base System Device" in the other devices section "Bluetooth and Other Devices" page of settings.

    Extra Info: The battery on my stealth stopped working. My laptop would not turn on at all, or keep a charge. I removed the internal battery, and now it allows me to use it normally, albeit always plugged in. However, this means that I cannot unplug the Core X Chroma without causing the Laptop to shut off entirely.

    If anyone may please give some insight I would be very grateful. I am beyond frustrated that a $400 product advertised as Plug and Play has caused me 9 hours of troubleshooting grief, without success. I'm sorry to say that if nothing comes out of this I will most likely never buy a Razer product again.
     

    Attached Files:

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >