Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Blade Stealth (Early 2019) Wi-Fi Issues

Discussion in 'Razer Support' started by retroClassicRosebox696, Mar 9, 2020.

  1. Hi there, I have a razer blade stealth 2019,

    i7-1065
    16Gb
    GTX1650
    13" FHD
    Intel wi-fi 6 ax 201

    I have had a highly annoying but easily replicatable flaw that I am dying to get rid of.

    Every hour, at xx.39 the laptop drops connection from my home wi-fi for 3-5 mins,
    after which time I am able to reconnect

    Every other device is fine, this is a problem specific to the razer blade.

    I have tried various solutions to try to get rid of this including:

    -Making sure I have the latest driver
    -Updating power settings to not affect the wi fi
    -changing the wi fi mode from ax to ac and back
    -update firmware on the router (Virgin Superhub 3)
    -Update adaptor settings to turn MIMO power saving to no smps

    so far I have had no luck and it renders some online games unplayable as you lose your progress or get kicked out of the group (Division 2/Destiny)

    Anyone had a similar issue or can recommend a process flow to solve?

    Thanks
     
    Last edited: Mar 9, 2020
  2. zachl2236

    zachl2236 New Member

    Hi I'm posting this reply on all the forum posts as this seems to be a major problem. I am having the same exact issue as well on my 2 day old Blade Stealth (Late 2019). It seems this is a known issue with the AX201 chip installed in the system. There are 2 other Razer forum posts about this exact issue with no solution from Razer yet. A quick Google search renders multiple other brands also having this exact issue in their systems. Intel has yet to fix it yet.
     
  3. I have exactly the same issue with a Blade Stealth 13 2019 (Intel AX200) and also with an add-on PCIe WiFi card I've installed on an alder desktop (Intel AX201). Both systems running Windows 10 Home. I had to disable the AX features on my router in order to have a reliable connection. My router is a Netgear Nighthawk RAX120 and I thought the problem is there.
     
    Last edited: May 3, 2020
  4. zachl2236

    zachl2236 New Member

    I also have a Nighthawk RAX120. Did disabling the AX features completely remove the WiFi issues? If so I might try that next as a solution. I also have considered trying the 2.4ghz network to see if that eliminates the issue.
     
  5. Have not tried 2.4G since it's very busy where I live. 5G and AX stalls in 10-20 minutes of medium/high sustained traffic. If I disable the AX from the router, the issue is "solved", but of course the connection it's AC only. So I upgraded to AX to not be able to use it... :slightly_sad:( Still not sure where the issus is, Netgear RAX120 router or Intel 201 WiFi card.
     
  6. zachl2236

    zachl2236 New Member

    I agree. I upgraded to AX to be able to actually take advantage of its benefits. I will change my settings to AC and report back if it also fixed my issue! I’m going to guess it’s not so much an issue with the RAX120 router but is most likely stemming from the WiFi card itself. There’s tons of other systems (Dell, Asus, Microsoft’s Surface line, etc.) that are also having issues with this card. It could just so happen that everyone who’s posting about issues is using an AX rated router? Maybe the 201 WiFi card is not playing nicely with the AX routers. Thanks for the possible solution/fix! No ones suggested disabling AX on the router itself let alone a positive result from any suggested fix so far. I’ll report back with my results!
     
  7. What happens in your case, you get disconnected? My connection is still up but the download speed drops to a few Mbps (under 5) and stays so until I reboot the computer or the router or disconnect manually and connect again. The other computers in the house (802.11ac) work fine when this happen, but the 802.11ax one also stalls sometimes during that, even though it may have been idle (no Internet traffic). Sometimes it just continue to work as usual, though. This is why I suspect the router.
     
  8. zachl2236

    zachl2236 New Member

    My case is exactly the same as yours. There’s no rhyme or reason as to why my download speeds suddenly drop but when they do they drop to most of the time below 1Mbps. If I toggle on and off the WiFi it returns back to normal network speeds (around 350 Mbps). The other system I have is a Surface Laptop 3 with the same AX201 card. It produces the exact same issue. I will be getting a Oneplus 8 Pro in the next few days that will have AX. I could test that to see if it produces the same issue.
     
  9. OK, then you may be lucky. Disable the AX from the router, it worked in my case. Not happy with the solution, but at least I can reliably use the Internet on the 2 AX devices I have. The AX would have been nice for accessing my 10G capable NAS; my Internet plan is well below what AX or even AC is capable of (it's only 250Mbps). Good luck!
     
  10. zachl2236

    zachl2236 New Member

    I really hope someone in the universe comes up with a viable solution so AX can actually be useful! Thanks for the possible solution. Fingers crossed I’ve had no speed drop as of yet on AC!
     
  11. zachl2236

    zachl2236 New Member

    Well my first speed drop happened this morning after switching to AC on the router. :slightly_sad: Did you also disable AX on your Wi-Fi card? If so, do you know which firmware version you're running for the Wi-Fi card?
     
  12. Sorry to hear that. :slightly_sad: I did not disable the AX from the adapter cards, only form the router. The router firmware was 1.0.1.118 (I have a ticket open with the Netgear support, they've accessed my network and been able to reproduced the issue with the AX, logged traffic, come up with some trial firmware, etc, but still have the problem.) The computer I've run tests on is a Razer Blade 13 model 2019, WiFi Intel AX201 160MHz firmware 21.30.2.1. The other computer is a modified Dell workstation desktop, I added an Intel AX200 160MHz WiFi firmware 21.80.2.1. The truth is I don't use any of these 2 computers; one is used by my wife and the other by my daughter. So perhaps the issue is still there even in AC mode, but much less frequent? After switching to the AC I tested the download for about 2 hours without hitting into the issue again, so I told my wife and daughter to let me know if they still see internet problems. Got no complaints so far... My daughter is still in elementary school and that Blade 13 laptop is way too powerful for her current needs, so I don't really expect her to hit into the issue. My wife is using the network in bursts: long times without no traffic at all, then spikes of heavy traffic, mostly to/from the NAS in the LAN. I'm working on a modified Blade 15 model 2018 with an Intel AC9260 and never saw the issue, although I'm using it daily for video conferences and heavy traffic, multiple VPN connections.
     
  13. zachl2236

    zachl2236 New Member

    Just posting back with an update. I have successfully solved/fixed my problem for now. It seems it was the router that was causing my problems. Out of last resort I went and purchased a simple TP-Link AC only router (AC1750). After using this router for 2 total days I’ve had zero issues with my WiFi dropping and I have consistent speeds. It seems my issue had to do with the Netgear RAX120.
     
  14. Thanks for the update. I can't return the RAX120, the window closed. But if I'll get complaints from my family, even with the current AC mode, then I guess I also need to replace the router. I'd still like an AX one, a truly functional one I mean. Wonder if such a thing exists at this moment... The 802.11ax seems not mature yet, the internet is full of issue reports.
     
  15. zachl2236

    zachl2236 New Member

    I’m also way past my return window for the RAX120. What I did was I kept my RAX120 functioning on the AX setting since all my other non-AX devices are working fine on it. And I set up the AC TP-Link router in another bedroom. So basically I have 2 routers for my apartment. Which is a little insane but, I didn’t want to completely stop using my Netgear router. So I opted into getting the $60 TP- Link router and just basically having that for my Blade Stealth and my Surface Laptop. The set-up is working fine for now. Surprisingly I’m getting the same WiFi speed from the $60 TP-Link as I am from the RAX120. So for $60 I’m now very happy that I at least have fast, functioning WiFi. Hopefully Netgear will fix the issue on their end and I can go back to using my AX router eventually!
     
  16. Yes, the speed should be the same with AC, unless you have a subscribed service of about 500Mbps or faster. The 802.11ac maximum speed depends on the radio PHY layer implementation (the AC chipset version) and also on the quality of the connection (when the link is weak, the speed is slowed down by the PHY until the BER reaches acceptable levels). The main reason I bought an AX router is to access my LAN network storage units at high speeds (my Internet plan is slow enough to be easily covered even by the basic AC implementation). Unfortunately, Netgear still hasn't solved the issue, I hope to get another firmware trial soon, but for some days they went silent...
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >