Razer DeathAdder V3 Pro: Driver Issues, Not detected on Synapse App

Discussion in 'Mice and Surfaces' started by megabully, Nov 14, 2022.

  1. megabully

    megabully New Member

    So after I bought the mouse, I used it wired, and it works fine for a couple of days, it detected on Synapse App and everything worked.

    Then after yesterday, I tried using it wirelessly connecting it to the wireless dongle, it works, but the Synapse App completely stopped detecting the mouse. I can't change DPI or any mouse settings, it also showed up as "Driver error" in window settings. Now even when I switch back to wired connection, the mouse still don't get detected on the Synapse App seems broken.

    https://imgur.com/aIEuOXU

    What I tried:
    1) I tried reinstalling the Synapse App multiple times, doesn't do anything.
    2) I tried reinstalling the driver in the Device Manager, doesn't do anything.

    I tried to search it online, there's literally nothing regarding DeathAdder V3 at all, not even driver/firmware software page on Razer website. [https://drivers.razersupport.com//index.php?_m=downloads&_a=view&parentcategoryid=76&nav=0]
     
    Quinny93 likes this.
  2. john14073

    john14073 New Member

    I am also experiencing this issue. We are not the only ones either. I have had this mouse for a little over two years and this seems to be a new issue.

    This is a comment I just made on another post very similar to yours:
    "
    +1 I am also experiencing this.

    I updated Razer Synapse 3.0 and now it doesn't detect my Razer Deathadder v2. Windows 10 claims there is a "driver error" just like OP.

    I have repaired, uninstalled & reinstalled, and modified Razer Synapse 3.0 several times each.

    I tried removing the device from Windows while the mouse is unplugged and Razer Synapse 3.0 not-installed, followed by reinstalling Razer Synapse 3.0 and finally re-plugging the mouse in and that did not result in a different outcome.

    Razer Synapse 3.0 behaves as if no Razer devices are plugged into my PC. As a result, the Calibration and Lighting tabs are missing and I am not able to see the controls for the mouse at all.

    As if this whole thing wasn't weird enough, my mouse now has the most unique lighting behavior I have witnessed on a device like this. The LEDs periodically illuminate, only flickering. When they do illuminate, it does the default Spectrum Cycling. When I first observed this I thought, "Oh, a wire is disconnecting and the lights are slowly going out." Until I realized the mouse is only flickering when my PC outputs audio. The mouse drivers are literally reacting to music and my friends in discord. It is the weirdest thing.
    "
     
    Quinny93 likes this.
  3. Quinny93

    Quinny93 New Member

    Hello guys, I've owned my Deathadder Elite for 4+ years with no problems what so ever an was experiencing the same problems the past 2 days.

    I spent multiply hours reinstalling Synapse multiple times even tried reinstalling the driver in device manager, until I final found a post only minutes ago caused by an incompatibility between Synapse and Riot Vanguard.

    https://insider.razer.com/index.php?threads/blackwidow-x-chroma-driver-error.89977/

    https://www.reddit.com/r/razer/comments/yrqdye/read_this_if_your_devices_no_longer_register_in/

    I uninstalled Riot Vanguard restarted my PC an my Deathadder Elite is finally showing up on Razer Synapse hope this helps you guys or anybody else seeing this forum!
     
    Last edited: Nov 17, 2022
    john14073 and FiszPL like this.
  4. megabully

    megabully New Member

    Yeaa, Razer Support reached out to me and suggested the same thing. Can confirm that removing Valorant and Riot Vanguard fixed the issue. Gotta quit Valorant I guess, lol.
     
    FiszPL and john14073 like this.
  5. john14073

    john14073 New Member

    WOW +1 for the tip to uninstall Valorant.

    Magically my mouse works like it always had. Cheers!
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >