Razer Goliathus Extended Chroma - BIG (few) problems....

Discussion in 'Razer Support' started by mini2109, Aug 30, 2022.

Thread Status:
Not open for further replies.
  1. mini2109

    mini2109 Member

    Welcome back.
    The amount of Razer hardware on my desk is slowly increasing.
    Unfortunately, I'm probably not lucky with these products ...

    This time it fell on a pad.
    Bought as new (as the seller claims) on one of the portals it seemed okay ... unfortunately the problem appeared after connecting.

    At first, when I plugged it into the usb port on the back - windows started alerting about "unrecognized device".
    Of course, nothing could be done except restart the computer.

    After this, the system after rebooting did not scream anymore, Synapse detected the shim and everything worked ... for a while.
    After I finished using the computer, I left it to go to sleep by itself.
    After a few minutes, when I returned, I noticed that all the devices (mouse, keyboard, guest) were already turned off (i.e. not lit) and the pad was still there.
    I woke up the system, entered Synapse and ... no shim.

    I did one more reboot.
    This time ... the computer didn't get up.
    He stopped at the logo of the motherboard manufacturer and didn't want to go any further.
    Restarting the system with the POWER button helped, but after that the shim did not work anymore.
    I guess she's causing some problem with the system, but what's the point ...

    Anyone had a similar problem?
     
  2. mini2109

    mini2109 Member

    I checked on the laptop.
    It is the same - after connecting, the message "USB device not recognized" is displayed
    I am surprised only once it worked and now it does not go.
    So it is probably "fate" and not my computer is to blame: D
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Sorry to hear about your ongoing concern with the newly purchased Razer Goliathus Extended Chroma. By the way, I replied to your PM. Let's continue our discussion privately.

    *Thread is now locked.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >