Razer Huntsman elite lag (Not working)

Discussion in 'Razer Support' started by Zero-Divide, Aug 17, 2018.

Thread Status:
Not open for further replies.
  1. Zero-Divide

    Zero-Divide New Member

    Hi everyone,

    last month my partner bought me the Razer Huntsman elite and i love it.

    However today i have logged into my computer and the keyboard is very laggy. usually i have to restart synaspe or the computer but today nothing helped.

    just to be clear i'm talking about the effects of Synaspe & the keyboard not typing anything.

    i tried restarting the computer multiple times with the USB's in or out, shutting down Synaspe but still nothing has worked. (i have also reinstalled synaspe)

    I did however take out the USB that powers the side lights and wrist lights. now the keyboard actually types, however the effects on my synaspe are still very slow.

    I use two effects. (Fire & Reactive)

    my issue ain't the fact that the effects are laggy. but with both USB's plugged in the keyboard does not work.

    any help would be appreciated
     
  2. Razer.Winteryang

    Razer.Winteryang Ice Bear Staff Member

    Hello there! We sent you a PM to help you out. We hope to hear from you soon!
     
  3. ShOcKeR87

    ShOcKeR87 New Member

    Mine is messed up bad too. I can’t even use it right now. The lights lag very bad and when I type it just makes a lot of the same letter and lags horribly. I’ve uninstalled and reinstalled, tried repairing, and restarted numerous times? What else can I do? Seriously about to return it.
     
  4. Razer.Winteryang

    Razer.Winteryang Ice Bear Staff Member

    Hey @ShOcKeR87, have you tried switching ports? Do you get the same result?

    Please send over the serial number of the keyboard via PM so we can further check on this.
     
  5. Tsanch

    Tsanch New Member

    I'm having the same issue. Have no clue why this is happening. I got this keyboard a week ago and loved it but now I'm very frustrated
     
  6. Razer.Winteryang

    Razer.Winteryang Ice Bear Staff Member

    Hey there, allow us to look into this. Just to verify, was the problem present straight-of-the-box, yes?
     
  7. Tsanch

    Tsanch New Member

    No. It worked fine for 3 days. It works fine when I unplug the wrist pad but when the wrist pad is attached it gets super laggy and sticky key issues.
     
  8. Razer.Winteryang

    Razer.Winteryang Ice Bear Staff Member

    Got it. I sent you a message please check your inbox.
     
  9. GOffrier58

    GOffrier58 New Member

    make sure you attach the wrist correctly i have an huntsman elite and got the same problem fixed with my method
     
    Zero-Divide likes this.
  10. Surprlsed

    Surprlsed New Member

    I got my huntsman elite and also the hyper flux and the rgb headphone stand. out of the 3 my huntsman elite rgb are very laggy and not smooth and when i attempt to run audio visualizer to see if its acutally lagging , it was extremely lagging and the lights just froze and i had to quit the program. the lights on the headphone stand and the hyperflux are fine but my huntsman even when its the only one plugged in it still lags, i dont know if it is my pc that it cant handle all 3 of them because my old keyboard the blackwidow chroma tournament edition works fine with the headphone stand and the hyperflux and does not lag on audio visualizer. I tried uninstalling razer many times , nothing seems to work
     
    Helisium likes this.
  11. Helisium

    Helisium New Member

    S
    Same keeps freezing in Audio Visualizer :/
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >