Razer Huntsman Elite Problems With Synapse

Discussion in 'Razer Support' started by Herlgers, Feb 11, 2019.

  1. Herlgers

    Herlgers New Member

    I'm sorry for my bad English

    I bought my Huntsman Elite razer at one time and at this time I tried to make it work properly however so far nothing, his problem is that it is not recognized by razer synapse 3, I have already tested it on other computers and it worked correctly, but in my not working, I have windows 7 Ultimate 64bits and my computer has all the requirements that ask in the manual but it is not recognized, on the other computers I tested on a windows 8 and it worked perfectly and then I tested on a windows 7 32 bit and the incredible thing that seems to have worked, already in my nothing, so I thought to format my computer and put the windows 10 but then I put a new hd with windows 10 installed but it still did not work, my computer only has usb 2.0 inputs and the product asks usb 2.0 ports, so I really do not know what's wrong for the synapse does not recognize it, I believe it could be maybe my processor which is an AMD FX (tm) -6300 Six-Core, but keyboard razer Huntsman elite Once worked on my computer when I deleted its drivers and erased the razer synapse, and deletedi its folders and erased even in regedit after doing this process the keyboard ran on my computer so I believed I would have solved it however when I put my mouse and my mouse pad the synapse asked for an update so I updated it but after that the keyboard did not work but the mouse and the mouse pad works perfectly, which I do not understand anymore what to do already I spent days tried to fix it and I believe I have done everything possible now I want to clarify a doubt the Razer Huntsman Elite only has support with Intel processors?

    just know that to pay 200 $ on such a product and having to pass headache to arrange it is a joke

    I know the hardware is incredible but the software is horrible and it is only for this reason that I believe that Corsair or Logitech is better, please fix it because I prefer Razer even! :frown_::frown_::frown_:
     
  2. Neozgred

    Neozgred New Member

    Check this topic.
    https://insider.razer.com/index.php?threads/synapse-3-not-reconizing-devices-under-windows-7.46942/

    I already write there that devices are not working properly under windows 7, but you said that it was working on Windows 7 32 bit computer what is strange for me as well. Anyway most of the people having that issue are on Windows 7. I also was checking with other computers with Windows 10 and it was working so i was sure that it is Windows 7, but i was not trying to install Windows 10 on my own PC so now im not sure anymore. Anyway good that you write so many things.
     
    Last edited: Feb 12, 2019
  3. Herlgers

    Herlgers New Member

    as in your post I have seen, but depending on your problem may be synapse update same but the strange thing is that it did not work for me even on windows 10,
    I believe that the problem is in the software and not in the hardware because it does not work on other computers or it does not rule out the possibility of being a keyboard problem you have already tested on other computers as well ?, windows 7 is good but windows 10 is better to install all drivers, but in my I tested with windows 7 and 10 on my computer and did not change anything, so I believe that the problem is not in windows 7, because in the manual says that it is compatible with windows 7 64 bit, but not 32 bits which I found strange because it worked on a 32-bit computer that I tested, now I believe it may be processor incompatibility and as in my post you read you can see that it is an AMD FX (tm) -6300 Six-Core, I believe you need an Intel, I do not know what your processor could tell me?
    Neozgred
     
  4. Neozgred

    Neozgred New Member

    I have I7-4790, so as you see it not working on intel CPUs as well.
     
  5. Herlgers

    Herlgers New Member

    which version of usb ports are you using? 2.0/3.0/3.1? I use 2.0 what the keyboard asks for but I do not know what else can be
     
  6. Neozgred

    Neozgred New Member

    3.0 for keyboard, 2.0 for the rest. I was replacing devices between ports without any changes. But before patch it was working.
     
  7. Herlgers

    Herlgers New Member

    I do not know what to do anymore because everything I thought it could be, now what I think it might be is lack of power being distributed to the keyboard which I think is strange but it is not impossible I use a 500w source but I discard this possibility, I recommend you format and put windows 10 on your computer and see if it works or not because I do not know what else can be
     
  8. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hey @Helgers, please send me a PM with a link to this thread so I can help you troubleshoot this. Would appreciate it if you can include a screenshot of how your Huntsman Elite appears in your Device Manager.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >