Razer Kraken 7.1 V2 keeps disconnection

Discussion in 'Razer Support' started by Licoricebizdepot669, Feb 9, 2021.

Thread Status:
Not open for further replies.
  1. Licoricebizdepot669

    Licoricebizdepot669 New Member

    Hi,
    I am using latest Synapse 2 drivers for my Kraken 7.1 V2. Recently it started to disconnecting 1-2 seconds and blocks mouse as well and continues to work properly.
    I also checked all usb ports and devices and turned off power saving on them (because in some forums it was saying can be related) but it did not help.
    Do you have an idea about solution?
    Where can I have older versions of Synapse 2 to test if it is really from the latest driver?
    Regards,
    Burak
     
  2. Im also having the same problems
     
    Licoricebizdepot669 likes this.
  3. Sun3ke

    Sun3ke New Member

    same issue. I have just read other forums, turns out this is an issue for many of us all of a sudden..
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Does the issue happen after connecting the headset to a different USB port or computer? Ensure that your device is plugged into your computer's USB port directly. If you are using a PC, connect the device to the rear USB ports and see if it helps.
     
  5. Sun3ke

    Sun3ke New Member

    I've tried all ports that I have on my pc and in the base station which I bought together with the headset - same issue. It works for maybe 30mins fine and then it starts to disconnect my keyboard and headset every minute or so, however, the base station seems to not be affected as light works, but the headset disconnects anyway. I've tried another headset and everything is perfect - no disconnection whatsoever.
     
    Licoricebizdepot669 likes this.
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I see. Does the disconnection happen while the Razer Synapse is closed or disabled?
     
  7. Sun3ke

    Sun3ke New Member

  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for conforming. Please send me a PM together your device's serial number so I can check its available updates. Let's continue from there.
     
  9. erra0918

    erra0918 New Member

    I have the same problem with my razer kraken kitty edition, I also sent a report via email. I hope you can fix this ASAP as I am using this device for my job, and It’s really frustrating.
     
    xeerocks likes this.
  10. Licoricebizdepot669

    Licoricebizdepot669 New Member

    it tried all ports but no difference. disconnection is random.
     
  11. Licoricebizdepot669

    Licoricebizdepot669 New Member

    exactly the same
     
  12. g4ttina

    g4ttina New Member

    me too, its getting super annoying and im very disappointed because it JUST started doing this a couple days ago and ive tried everything
     
  13. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! I replied to your PM. By the way, I recommend changing your username as it is against our house rules (sharing personal or device details publicly).

    Hello everyone! Thanks for sharing your feedback. Please send me a PM together with your headset's serial number so I can further assist you. I'll pick it up from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >