Razer Kraken 7.1 v2 Oval - won't show up in Synapse 2 - have tried everything - please help

Discussion in 'Razer Support' started by leetvisionFlirt420, Dec 8, 2018 at 2:00 PM.

  1. leetvisionFlirt420

    leetvisionFlirt420 New Member

    Chat support was useless - have reinstalled software like 20 times, updated bios, updated WIndows, updated USB drivers

    The headset works. Even if I right click on synapse, I see an option for Razer Kraken 7.1 v2 Oval, but if I click on it nothing happens

    In Synapse, I just see three options for registering the product and a few website options but no product and it prompts me to connect an applicable device

    I have tried plugging into every USB port. Seriously, this software sucks. How do I get it to show up? The only reason I bought it was to configure 7.1 and I can't do that without the synapse connection
     
    pancholr likes this.
  2. BlackFireDragon

    BlackFireDragon Active Member

    Try to connect your headset to other pc this is the best start to give you more info where to look issue,
     
  3. leetvisionFlirt420

    leetvisionFlirt420 New Member

    I connected to my laptop and it worked fine. It doesn't work on my desktop - I can configure things on my laptop
     
  4. BlackFireDragon

    BlackFireDragon Active Member

    Try to remove all razer softwere after uninstall remove files from appdata nad programfiles reboot and install only synapse cheack you can also remove device from device menager to force windows to reinstall headset driver.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >