Razer Kraken Kitty Headset dis- and reconnects

Discussion in 'Razer Support' started by 102030F26700229, Jul 25, 2021.

Thread Status:
Not open for further replies.
  1. 102030F26700229

    102030F26700229 New Member

    Hello everyone!

    I own a Razer Kraken Kitty Headset for half a year now. At first I had no issues with it and I was very happy finally owning one, since i wanted to buy it for a long time. But after a few months of using it quite often (I was very gentle with it) it started to disconnect with a popping sound, only to reconnect after 2 sec with another pop.
    When it began to do it it was every 2 or 3 hours, so it was annoying, but still bearable. But after 3 weeks it got worse and worse, and at one point it disconnected every 30 seconds, so it became pretty much unusable. There was even one time where it didn´t even reconnect anymore.

    Of course I looked it up on the internet and read about other people having the same issue, but nothing that worked for them did for me. I tried all of my USB-Ports, deinstalled Razer Synapse, reinstalled the headsets driver, checked the cable, whether i can force-disconnect it or not, and i updated all of my PCs drivers just in case. But nothing worked. (At the beginning of the disconnecting i tried it on another pc for 2 hours and it worked completely fine, but it might just have been coincidence, since it wasn´t that bad when it started.)

    So I am back using my old headset, hoping that someone can help me.

    Thanks for your help in advance.
     
  2. I've been having the exact same issue with the Kitty Kraken edition for years and even had Razer replace the headset with a new one and the issue persists. Either it is a design flaw with the headset itself or there is a bug with how the operating system interacts with the headset. I've tried dozens of fixes, from replacing usb ports, to updating drivers, to changing settings, and it always comes back eventually. Razer has never offered an explanation as to why this has happened or what they plan to do about it, but as cute as the headset is I recommend finding a new headset. Because razer doesn't seem to care.
     
  3. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    Appreciate your sharing all the troubleshooting steps that you've done. Since the headset worked on a different PC, let's try to isolate the issue by following the steps on this page. But if the problem persists, PM me the serial number of your headset along with a screenshot of your MSINFO32. I can use those to verify the model of your heads, take a closer look at your system and look for other possible solutions.


    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >