Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Kraken Kitty stopped working... Need help

Discussion in 'Audio' started by virtuallyhexed, Nov 10, 2020.

  1. virtuallyhexed

    virtuallyhexed New Member

    Hi there. Around February this year I bought a Razer Kraken Kitty Edition headset and I've absolutely loved it.
    I've now had multiple issues where it has repeatedly disconnected and reconnected, making a popping sound when the audio goes off, and I get a notification on my computer that windows doesn't recognise a USB.
    I have tried quite literally everything I've found so far, I've tried all day.

    I've made sure everything is up to date, I've uninstalled them from my device manager to try and work things out, I've been in the registry.. Nothing has worked. No matter what USB port I've used it in whether it's on my monitor (it's original place) or somewhere else.. it does the same thing. I'm starting to get pretty desperate since I'm not the best in the world at figuring out what the problem is with stuff like headsets and I'd appreciate any advice
     
    Neo_L33 likes this.
  2. Neo_L33

    Neo_L33 New Member

    Have you tried contacting Razer Support? I assume the headset should still be covered under the warranty program.
     
  3. virtuallyhexed

    virtuallyhexed New Member

    I've just put a ticket in but after I've looked at some forums on the same headset people have had the same issue with no resolution
     
  4. ItsDanaNow

    ItsDanaNow New Member

    Been having the same issue across two separate headsets at this point, after Razer replaced the first ones saying it must be a hardware issue (obviously not). I'm still running around in circles doing everything Support suggests but nothing helps. After way too much research it seems like Windows just sometimes has issues with USB audio right now and we're just screwed until an update hopefully fixes it.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >