Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Lancehead issues

Discussion in 'Razer Support' started by Trakannon, Aug 24, 2020.

  1. Trakannon

    Trakannon New Member

    Hiya,

    So today I encountered an issue with my wireless razer lancehead. This device is just over 27 months old, so is now out of warranty.

    I use it wireless with my work PC and then wired with my home PC.

    Today it stopped working in wired mode and after some testing I have the following issues:

    1) the mouse works wirelessly when synapse is on - works fine, lighting, macros everything.
    2) with synapse off, and in wireless mode, the cursor moves but no clicks are registered and no lighting. Right mouse doesn't do a thing etc.
    3) when I plug the cable in, the mouse is not detected by synapse at all. I cannot see any charge light, the mouse does not work at all in wired move (switched on or off)

    Fault could be that whatever circuit controls the wired connection has blown, but the device still works in wireless mode - although for how long I am not sure as synapse has never really reported the battery level correctly.

    I have attempted to perform a firmware update, but the 1st option (wireless) does not recognise or allow me to proceed with the update with synapse on OR off.

    The wired option of the firmware update does not let me update as the mouse is not recognised.

    What I have done:
    1) Tested the cable can pass charge to other devices (man o war, leviathan mini) - this works
    2) Tried multiple USB ports for the mouse - same results - works wireless with synapse, 'half works' (well cant click, so not really) wireless with synapse off. Doesn't work at all wired.
    3) Tried different PCs (2 other machines) - same results as above
    4) Repaired and reinstalled synapse completely (on multiple machines)
    5) used harsh language

    Is my mouse dead? I wouldnt expect a mouse to only last just until its warranty is up. I did have an opportunity to RMA it because the wireless dongle fell apart, but i managed to superglue the dongle back together and that has been working fine since (it was just the housing.. seemed a complete waste to return an entire mouse although there were no spare dongles available).

    Has anyone else has this issue? Right now it feels like it is an 'ethereal' mouse like those items in diablo 2 which were awesome but had limited life.. as soon as the remaining battery is gone this things gonna stop working completely!

    Am I being unreasonable to expect this device to last longer than 27 months? The old copperhead and deathadder that I replaced with this still work and they're ancient..
     
  2. Trakannon

    Trakannon New Member

    Nada? thats a shame :slightly_sad:

    I've replaced it today with a Logitech G502 as I hear great things about them but time will tell, maybe i'll look at another Razer mouse in the future as my experience with the wired copperhead and deathadder were positive.. but the lancehead in this instance has failed me and I the reviews of the Basilisk were a bit underwhelming.

    It is now operating in a much reduced capacity, it wont work at all without synapse but does appear to accept charge from the cable, although it cannot be used whilst charging as the cable results in the mouse vanishing from synapse completely. No lighting works on it any more in any configuration and the battery readout does not work. Completely feels like it is a hardware fail at this point, which is unfortunate as I hope a 'lifespan' has not been built into razer products... especially considering the premium prices!
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >