Razer Nommo Pro loud humming after turning on.

Discussion in 'Audio' started by webBubbleGumfast857, Apr 16, 2019.

Thread Status:
Not open for further replies.
  1. webBubbleGumfast857

    webBubbleGumfast857 New Member

    When I am away from home I tend to completely turn off my pc and the speakers by pressing the button behind the subwoofer. After that I turn off the coupler which has a switch and when I come back home I turn on everything including the speakers I get loud humming from them which is only fixed when i turn them off from the button on the subwoofer while they are turned on. So is this normal or is the high current that flows after being turned off for a while causes this?
     
    Last edited: Apr 16, 2019
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    Try connect suboofer on difrent power outlet the best will be in difrent room and see if the behawior will be the same. Also can you cheack if your power outlet have grounding ?
     
  3. webBubbleGumfast857

    webBubbleGumfast857 New Member

    Yeap my power outlet is grounded.
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    Ok can you also tell me if you have connected extension cord to outlet and speakers to it or speakers are connected direct to outlet. Cheack also speakers on difrent outlet in other room if you can you can connect difrent extension cord to make sure this dont give you disturbances in the transmission of electricity this is most time the issue when speakers hum becose you hear flow of electricity.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >