Razer Ripsaw HD - Passthrough Output No Signal

Discussion in 'Razer Support' started by neotees, Feb 2, 2022.

Thread Status:
Not open for further replies.
  1. neotees

    neotees New Member

    Hi Team,

    I recently purchased a Ripsaw HD from Razer eBay AU.
    It detects fine in OBS and I am able to view the video and audio stream from a Nintendo Switch in OBS preview.
    There is no passthrough signal from the output HDMI port however, I am using the included Razer HDMI cable for the output but it does not seem to passthrough a video signal.

    I've tried different HDMI cables, a different screens, plugging in the included USB cable first, plugging in the HDMI cables first, nothing seems to enable HDMI passthrough output from the Ripsaw HD.

    Main PC Specs:
    AMD 3950X
    RTX 2080 Ti
    Windows 10 Pro
    Synapse 3 updated. (Does not display as an attached device in Synapse 3)
    Latest OBS release 27.1.3
    Nvidia display drivers updated.

    Also tested on a Razer Blade 14 (whilst charger is connected) in case it was related to the PC above:
    AMD 5900HX
    RTX 3080
    Windows 10
    Synpase 3 updated. (Does display as an attached device in Synapse 3)
    Latest OBS release 27.1.3
    Nvidia display drivers updated.

    Screens tested:
    TCL X925 65" TV HDMI 2.1 port
    LG CX 65" TV HDMI 2.1 port
    BenQ XL2420Z Monitor HDMI1.4 port

    Screencap of working OBS preview:
    https://imgur.com/seX7gbr

    Any advice that you could provide is greatly appreciated. Whilst my usecase is to simply play using the preview window so that I may screenshare with friends on Discord, I do want to ensure that the unit is working appropriately, thanks in advance.
     
    Last edited: Feb 3, 2022
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >