Razer synapse 2.0 not detecting Naga Epic Chroma or Wolverine

Discussion in 'Razer Support' started by Phjes11, Mar 30, 2019.

Thread Status:
Not open for further replies.
  1. Phjes11

    Phjes11 New Member

    Hi folks,

    I just recently rebooted Windows 10 on my PC, and for some reason Synapse won't detect my Naga Epic Chroma mouse any longer, all I get is what you see on this screenshot.

    [​IMG]

    Windows' got no problem finding the mouse, and the drivers are fully up to date. Problem is, that I need Synapse to remap my keybindings.

    I also bought a Razer Wolverine Tournament Edition a few days ago, which Synapse aren't detecting either.

    I've spent the last 2 days searching for solutions for this issue. Tried every troubleshooting tips I could find on google and youtube, but to no avail.
    I can't even count how many times I've uninstalled and reinstalled the Synapse software, and the drivers for my devices. This is really starting to get on my nerves.
     
    latryna likes this.
  2. latryna

    latryna New Member

    I have exacly same issue. After i bought mice i made an account and register for it warranty as always do.
    First time I had this problem a few months ago. Sloved by clicking on register warranty in synapse. after redirected and checked product warranty status, turned out that the data i added at the beginning disappeared. I Type SN and ID again. And app start to working correctly. I tryed to slove it in same way today but have new issue, Cliked next step shows a red text on the top of webside with "Error(!):Device is Hidden" information. Finally i start to chat with support. They gived me instruction with i did but without succes. I will continue tommorow. Maybe they give me some other solution.

    Software Support
    1. Kindly uninstall Razer Synapse from your PC and delete all files in C:\Program Files (x86)\Razer and C:\ProgramData\Razer directories. These folders may hidden by default, so please be sure to unhide them. We want to ensure that there are no residual files remaining that may corrupt your installation. This is important so please do so. Restart your computer afterwards.

    2. Go into device manager, go to Keyboards/Audio inputs and outputs/Mouse and other pointing devices, uninstall HID Keyboard/Mouse Drivers and all other Razer product drivers, and restart your PC. Be sure to select delete drivers as well when uninstalling. Restart your computer again.

    3. Turn off all Firewall and Antivirus software to prevent any conflicts. Download and install the latest version of Microsoft .NET Framework (4.5 or higher) at http://www.microsoft.com/en-us/download/details.aspx?id=30653 (In some cases, you may need to uninstall the older version on your system). Restart your computer again.

    4. Install the latest version of Razer Synapse that can be downloaded from the link below, and restart your computer again.


    Synapse 2:
    http://rzr.to/synapse-pc-download

    NOTE: Please do not reuse a previously downloaded version of the Synapse installer. Kindly redownload and reinstall Synapse
     
  3. Phjes11

    Phjes11 New Member

    Yeah, I've done those 4 steps several times now, and it solved absolutely nothing.
    Please let me know if you find a solution. I'm starting to tear my hair off, out of shear frustration.
     
  4. latryna

    latryna New Member

    Finally i fix it. Part nr 2 form support solution is most importat i think. From Dev menager removed all Hid/Usb devices and deleted drivers. When Keyboard, audio, and razer mouse stop to work i unplugged it, plugged my old mouse and restarted. After boot up Removed all razer soft, reg keys and files using BCuninstaler.

    (Bulk Crap Uninstaller. Great freeware tool btw) it can make silent uninstalls, remove reg keys, clear folders and autorun. Need to be run in admin mode of coz.

    When i purge all crap restarted PC. Then turn OFF Naga Epic Chroma, place it on recharge dock. Plugged RD to usb and swich mouse ON. Then Installed synapse 2.0, login, let the auto update ends, restarted.
    Toke a deep breath and double click on icon.. Works..

    Here is link to this Awesome tool. Freware, no adds, and hidden shit. Portable
    version https://www.bcuninstaller.com/ I did few screenshots. I hope it will help. Good Luck.

    bc3.JPG bc2.JPG bc.JPG
     
    Last edited: Mar 31, 2019
    Phjes11 likes this.
  5. Phjes11

    Phjes11 New Member

    Glad it worked out for you mate. Unfortunately it didn't for me. Guess I'm gonna have a chat with support myself then.
     
  6. i have the some issue. Someone that can help me ?
     
  7. J'ai le problème. Quelqu'un qui peut m'aider?
     
  8. Lauriat

    Lauriat Title: Entitled

    Hey guys! For those who are having the same issue that hasn't still been resolved, feel free to drop me a PM. Please make sure to include the link to this thread as well. I'll be waiting. Thanks!
     
  9. Niennasill

    Niennasill New Member

    My mice Naga Epic Chroma not detecting by Synapse 2.21 or 3.

    So far method I tested:

    1. Different USB ports
    2. Uninstall - Reinstall synapse
    3. Clean windows installation
    4. Update Synapse under settings.
    5. Wired and Wireless connections ( with Uninstall - Reinstall synapse )


    Mice product serial number : (*Removed for security purpose)
     
  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member


    I've replied to your PM., let's continue from there.
     
  11. Phjes11

    Phjes11 New Member

    Sent you a PM
     
  12. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >