Razer Synapse 2 and 3

Discussion in 'General Discussion' started by Swain, Apr 5, 2021.

Thread Status:
Not open for further replies.
  1. Swain

    Swain New Member

    Hey

    I have Blackwidow v2, Deathadder v2 and Kraken 7.1 v2, but I can't use only one synapse, I have to install both, because the Kraken 7.1 v2 don't have support on synapse 3.

    Is there any solution ?
     
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    No solution for this, you have to have both Synapse versions installed.
    My ManO'wars are on Synapse 2.0 too, while the rest is on Synapse 3.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >