Razer Synapse 3 doesn't detect my drivers anymore

Discussion in 'Mice and Surfaces' started by radioHarvestGoldboard912, Nov 15, 2022.

  1. So I have my Razer mouse (DeathAdder Elite) for about one year and I had the same exact model right before for again about an year long. I also have a Razer headset (Razer Kraken Tournament Edition) for about a year and a half now, I was using razer synapse ever since I ever bought my first mouse and it always seemed to work up until couple days ago (about 3 days), as if one day I woke up. opened my computer and it decided it doesn.t want to detect my devices anymore, because of that I don't have any access to my mouse settings i once had and I can't change my DPI or any mouse settings, it doesn't even show I have the mouse on the app, it also showed up as "Driver error" in window settings. as for the headset, from the day my products disappeared from the synapse, my audio was crashing and it kept sending the audio troubleshoot. What I tried:
    1) I tried reinstalling the Synapse App multiple times, doesn't do anything.
    2) I tried reinstalling the driver in the Device Manager, doesn't do anything.

    I tried to search it online, there's literally nothing regarding DeathAdder Elite or Razer Kraken Tournament Edition at all, not even driver/firmware software page on Razer website. [https://drivers.razersupport.com//index.php?_m=downloads&_a=view&parentcategoryid=76&nav=0]
    And also sorry for bad English
     
    pancholr and john14073 like this.
  2. also ignore my pfp i didnt had time to change it
     
    Lairdren likes this.
  3. john14073

    john14073 New Member

    +1 I am also experiencing this.

    I updated Razer Synapse 3.0 and now it doesn't detect my Razer Deathadder v2. Windows 10 claims there is a "driver error" just like OP.

    I have repaired, uninstalled & reinstalled, and modified Razer Synapse 3.0 several times each.

    I tried removing the device from Windows while the mouse is unplugged and Razer Synapse 3.0 not-installed, followed by reinstalling Razer Synapse 3.0 and finally re-plugging the mouse in and that did not result in a different outcome.

    Razer Synapse 3.0 behaves as if no Razer devices are plugged into my PC. As a result, the Calibration and Lighting tabs are missing and I am not able to see the controls for the mouse at all.

    As if this whole thing wasn't weird enough, my mouse now has the most unique lighting behavior I have witnessed on a device like this. The LEDs periodically illuminate, only flickering. When they do illuminate, it does the default Spectrum Cycling. When I first observed this I thought, "Oh, a wire is disconnecting and the lights are slowly going out." Until I realized the mouse is only flickering when my PC outputs audio. The mouse drivers are literally reacting to music and my friends in discord. It is the weirdest thing.
     
  4. Quinny93

    Quinny93 New Member

    Hello guys, I've owned my Deathadder Elite for 4+ years with no problems what so ever an was experiencing the same problems the past 2 days.

    I spent multiply hours reinstalling Synapse multiple times even tried reinstalling the driver in device manager, until I final found a post only minutes ago caused by an incompatibility between Synapse and Riot Vanguard.

    https://insider.razer.com/index.php?threads/blackwidow-x-chroma-driver-error.89977/

    https://www.reddit.com/r/razer/comments/yrqdye/read_this_if_your_devices_no_longer_register_in/

    I uninstalled Riot Vanguard restarted my PC an my Deathadder Elite is finally showing up on Razer Synapse hope this helps you guys or anybody else seeing this forum!
     
    Last edited: Nov 17, 2022
    Lairdren and FiszPL like this.
  5. john14073

    john14073 New Member

    Uninstalling Valorant worked for me
     
    FiszPL likes this.
  6. Nate_Pacific

    Nate_Pacific New Member

    Hey guys,

    i just got my first razer deathadder v2. I plugged it in my laptop as advised to charge it but it seems like its not connecting properly. My laptop constantly makes the sounds when you plug in and out a USB... Can this be the same problem as mentioned above? I never had anything razer so im kind of lost...
     
  7. john14073

    john14073 New Member


    If you have Valorant installed then it may be your issue.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >