Razer Synapse not recognizing Razer BlackWidow X Chroma

Discussion in 'Razer Support' started by Nephalen, Apr 13, 2019.

Thread Status:
Not open for further replies.
  1. Nephalen

    Nephalen New Member

    I have been using my Razer BlackWidow X Chroma for a few months now and it's been working fine.
    Recently I decided to update razer synapse since it kept bugging me to do so, after the update though I noticed that the application no longer recognized my keyboard. When I try to open the chroma module for example it simply tells me "This module requires a Razer Chroma device". I also don't see my keyboard under devices in Razer Synapse.

    What I have tried thus far:
    Uninstall and reinstall Razer Synapse
    Switch USB ports with my keybaord
    Uninstall all HID keyboard and mouse devices as well as Razer BlackWidow X from the device manager
    All the steps above have been followed with restarting my PC, I have also tried combining the steps like uninstalling all drivers and uninstalling the application at the same time.


    The keyboard still works just fine and I can use it to control the computer, any razer specific features (Like playing with the lights) do not work however.


    Thanks in advance.
     
  2. Nephalen

    Nephalen New Member

    Update:
    I tried installing Razer Synapse 2, and that version of the application recognizes my keyboard. I don't consider this a solution though as the UI and functionality in this version are not as good.
     
  3. Same problem, I have tried all the solutions people recommended and its still not detected by Synapse.
     
  4. razer.redpanda

    razer.redpanda Guardian of the Forest Staff Member

    Hi there guys! Can you PM me the build number of Synapse 3. Please include the link to this thread as well. I'll assist you from there.
     
  5. Nephalen

    Nephalen New Member

    I am sorry for not responding in along time, I have simply not been near my computer.
    I updated from windows 7 to windows 10 and now I am no longer experiencing any trouble.
     
  6. razer.redpanda

    razer.redpanda Guardian of the Forest Staff Member

    Thanks for the update. Let me know if you need more help.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >