Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Synapse

Discussion in 'Razer Support' started by radioGrizzlySAPPHIRE416, Mar 20, 2020.

Thread Status:
Not open for further replies.
  1. It started after today's winblows update..and it gets stuck at looking for the .msi package, it can't / won't see it at all.. i have re-downloaded the files and tried four times...re did audio drivers too...Nothing. I even tried the new version, nothing worked in that because it's not for my headset. So , whats the solution? other then never buying products from this company again... this is not the first time I have no audio after an update or a crappy install issue..I am rather sick of half done forced updates that seem to aim at Marketing rather than performance.
     
  2. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey @radioGrizzlySAPPHIRE416! Sorry to hear about your headset's concern. Just to confirm, does the Razer Synapse didn't detect your headset or the headset has no audio? Does the issue occur when plugging in the headset to a different USB port or computer? Please send me a PM together with your device's serial number via PM. Let's continue from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >