Recent Connection Issues: Razer Huntsman, Kitty Kraken, and Basilisk Mouse, and Base Station

Discussion in 'Razer Support' started by MemeGoddesss, Mar 9, 2021.

  1. MemeGoddesss

    MemeGoddesss New Member

    A new issue began about 1-2 weeks ago, my razer products began to have trouble staying connected. I would get the constant USB disconnection noise and the chroma lights would rebegin their cycle; My Kitty Kraken headphones would also pop, turn their original color of green, and on occasion blow my eardrums out. My Huntsman keyboard will type however my Basilisk mouse has also begun to become laggy. They will cut out every 5 minutes or multiple times in a row.
    I have had these products since August 2020 and have never had this problem until now. I believe a possible Synapse update has caused a bunch of issues; I have seen other people in forums on here complaining about this around the same time these problems began arising for me- I would have added this to that forum however it is now "closed".
    I don't know what to do. I have changed all the power options to not allow my computer to turn off my keyboard, mouse, headphones, and base station in device manager on "Human Interface Devices" as well as "Universal Serial Bus Controllers". My last resort was installing and reinstalling Synapse; that did nothing. When I completely uninstalled Synapse my products became usable and the constant disconnection stopped.
    I am a student and I rely heavily on these products to do all my online college classes. I am so frustrated and stressed out, especially because I have spent a good amount of money on these as well.
    Does anyone or Razer have any ideas of what I should do?
     
    eviemayhem likes this.
  2. ChromaLife

    ChromaLife New Member

    Would you be happening to use a Ryzen 3000 or 5000 system? I'm having a few problems with my new Huntsman Analog. This could be tied to some USB instability on the Ryzen chipset. I'd look into maybe flashing the new BIOS when the fix comes out, at least that's what I'm hoping fixes my intermittent problems.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >