Ripsaw HD: Passthrough at 4K as expected, but streaming not correct

Discussion in 'Razer Support' started by TheIcemanCometh, Apr 19, 2019.

Thread Status:
Not open for further replies.
  1. TheIcemanCometh

    TheIcemanCometh New Member

    I got my Ripsaw HD yesterday and I'm having pretty significant issues getting it set up to the way I've read it's supposed to work. I am using the Ripsaw HD as a replacement for an Elgato HD60 S, as there are some things about that device I really don't like (which is not a topic for discussion here).

    I have the passthrough port of the Ripsaw HD doing directly to my LG 4K monitor, and the output of the source gaming PC going to the input port of the Ripsaw HD - works as expected when I set the resolution to 4K. Audio is also present as expected. However, when trying to get Streamlabs OBS (SLOBS) set up correctly to output 1080p to my streams is not working. I also have no audio coming through to SLOBS.

    a. I have installed Synapse, although it doesn't seem necessary for the basic operation of the device.
    b. I have added the Ripsaw HD as a video capture device and it shows up as "Razer Ripsaw HD HDMI"
    c. I have tried setting Resolution/FPS type set to "Device Default" and "Custom" with resolution as 1920x1080p - same result
    d. Audio is set to "Output desktop audio (WaveOut)". I have also tried the (DirectSound) but no luck.
    e. I'm using high-speed HDMI cables for all connections (including the provided cable)
    f. I am not using the provided audio cable, as I would expect all audio to go through HDMI
    g. I have made no other changes to SLOBS from what I was previously using

    What am I missing here? Is there a setting somewhere I'm missing? As mentioned, my understanding of this device was that I could "game at 4k while still streaming at 1080p", but I'm just not seeing it. This is the only reason I purchased it.
     
  2. TheIcemanCometh

    TheIcemanCometh New Member

    UPDATE: On the gaming PC, I was seeing that audio is going out of the source "Ripsaw HD" and volume meters were showing output. So I had to go into SLOBS and add an Audio Input Capture source and set that to "Microphone (Razer Ripsaw HD HDMI)", and I am now getting the audio coming from the gaming PC.

    Video in SLOBS is still showing as 4k instead of 1080p. Based on the descriptions of the device, it should be downscaling to 1080p and it just doesn't look like it's doing it.
     
    Last edited: Apr 19, 2019
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Let us look into this. Can you share a short video of the issue?
     
  4. HafbAlbin0

    HafbAlbin0 New Member

    I’m having similar issues with mine, my stream is constantly lagging/clipping until it freezes but no frames are said to be getting lost
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Please share a short video of the issue so we can take a closer look.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >